x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How can I stop particles with -Z Constant Acceleration on collision?

I want to make GPU particles stick to a surface, but unfortunately I have a Constant Acceleration module with a downward force (-Z) which makes the particles slide down any vertical surface. Is it possible to completely freeze a GPU particle after collision?

The only workaround I found is to apply another constant acceleration in the direction of the surface so that the particles are pushed frozen against the surface, but that doesn't really solve the problem.

Product Version: Not Selected
Tags:
more ▼

asked Apr 23 '14 at 05:48 AM in Using UE4

avatar image

Icesolid
1 1 2 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Use the Depth Collision module and set the response method to Stop.

Even with Resilience set to 1. the particles should stop and stick.

alt text

stopcollide.jpg (22.7 kB)
more ▼

answered Apr 26 '14 at 02:01 AM

avatar image

[Epic]homeRye STAFF
1.2k 22 3 42

avatar image Icesolid Apr 26 '14 at 05:56 AM

The GPU particles keep being updated after the stop response (I should have precised this in my initial message). There's about 15 frames between each shot:

Images (can't seem to be able to publish my message with attachments)

avatar image xlar8or Sep 11 '16 at 12:47 PM

I have the same issue, i can't get the particles to stop. Have you figured out the way to fix this? Thanks.

avatar image mettam Sep 27 '16 at 05:08 AM

That answer shouldnt be tagged as an answer. I have the same problem. The particles keep slipping through the floor.

Does anyone know how to make them stop after they bounce and rest on the surface of the floor?

(comments are locked)
10|2000 characters needed characters left

Hello,

I had the similiar issue with particle mesh. (I was emitting rocks that rotate on the ground a bit but it sliped down on prone surface just like your GPU. I solved it by reducing particle number of collisions on about 40 (emitted like 20rocks) and set collision completion option to freeze. The more collision it had, the more it slipped so if you manage to somehow reduce the collision that are happening constantly on your GPU it could be the way. I know this is not the best answer for the scene depth collision for GPU. But I think you could set the response method to stop like homeRye said, but also set the friction to higher value. Let me know if that solved the problem.

more ▼

answered Apr 28 '17 at 08:54 AM

avatar image

Menoa The Wise
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question