x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editable values reset on placed actors

Hey there,

got an annoying 'bug'. Don't even know if it's a bug, but it's pretty annoying.

I got a baseclass "LevelNode" and different childs of it. The baseclass has a struct with Actor References to other LevelNodes and a few other variables, like texts, bools, etc.

The childs are placed in the map and connected by filling in the struct references. Like "Left level" etc.

Example pictures:

http://puu.sh/lsfU8/c3af1c05af.jpg

Filling in these information is a lot of work as soon as you have a few of them in your level.

Now, from time to time, without me knowing what i could cause, these variables reset to their default values.

I'm not even touching the LevelNode classes. Neither the base nor the child classes. So i need to fill out all of the data again and again. Is that a bug? Also had this in 4.9, but after updating to 4.10 it didn't change.

If nothing helps, i can provide the project, but as i said above, it doesn't happen every time, so you might need to play around with it till you find the result.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 20 '15 at 01:46 PM in Bug Reports

avatar image

eXi
6.8k 332 184 467

avatar image Rudy Q ♦♦ STAFF Nov 20 '15 at 04:16 PM

Hello eXi,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end (I understand it doesn't happen everytime, however the steps still help)?

  3. Could you provide screen shots of any blueprints that may be involved?

avatar image eXi Nov 21 '15 at 12:27 AM
  1. I don't think so. It's only appearing at random times, but i might have at least an idea WHEN it could happen.

  2. Well i can tell you what the setup is about, but i don't think that the setup alone is causing this.

  3. I will tomorrow.

I have a BaseClass. It has the following variables:

A struct with 4 reference variables of the BaseClass type, called left-, right-, top- and bottomlevel. A string or name variable for the name. 2 ints for World and Level Number and an int called NodeNumber.

Name and the World/LevelNumber are just to display them on the UI. NodeNumber is to have all Nodes ordered from 0 to n-1 (n Nodes in total).

And the 4 reference variables are there to link other Nodes that are connected to the current one. So i can have 4 different ways i can move to the next node.

Here is a video of the system (starts at 00:08) https://youtu.be/T8sgODPw0BU?t=8s

The nodes where the Character stops, that are the level nodes. Like a Super Mario overworld.

And these nodes are placed in the world. And the values just reset from time to time. I will try around if i can find the cause and try to redo this in a client project, but i highly doubt that i can reproduce this in a clean project ):

Well, thanks for your time so far, since it's weekend we will read at monday (: Have a nice weekend Rudy!

avatar image eXi Nov 21 '15 at 12:29 AM

Oh i forgot. I might think that this happens as soon as i compile the AI Controller that is controlling the Character. I have no idea why, because the AI controller is just working with an Array of all nodes and an index of the current node (that's what the NodeNumber is for). If i press RIGHT, the Controller gets the Current Node from the Array, checks if the RightLevel in the Struct is valid, and then tells the controlled pawn to move there.

So no idea why the Controller COULD cause the reset, but i will check that over the weekend!

avatar image Rudy Q ♦♦ STAFF Nov 23 '15 at 06:45 PM

Hello eXi,

Thank you for the information that you have provided. When you get a chance to share your screen shots I believe these will help further narrow down what issue it is that you are experiencing. Also, could you explain a further what exactly it is in the video that I should be looking for?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello eXi,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Nov 30 '15 at 07:16 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 523

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question