x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.10 Unreal Engine / Editor crashes on launch

New install on a formatted SSD. Windows 7.1 with SP1 and latest updates.


MachineId:EF5B74264719E1A2599DD4AF88EF1A2A EpicAccountId:4055c744bcdc41d6b3fbe6fc62e2f7e4

Unknown exception - code 00000001 (first/second chance not available)

"Assertion failed: GConfig->GetBool( TEXT('DevOptions.Shaders'), TEXT('bAllowCompilingThroughWorkers'), bAllowCompilingThroughWorkers, GEngineIni ) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Engine\Private\Shad

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\misc\outputdevice.cpp:374] UE4Editor_Engine!FShaderCompilingManager::FShaderCompilingManager() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:796] UE4Editor!FEngineLoop::PreInit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:1360] UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:110] UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

Product Version: UE 4.10
Tags:
more ▼

asked Nov 21 '15 at 02:29 PM in Bug Reports

avatar image

The Dark Enigma
46 1 2

avatar image Kallex Nov 22 '15 at 06:16 PM

Same behavior on my machine. I didn't start from scratch but updated Git to release, ran the Setup.bat (running prerequisites) and GenerateProjectFiles and rebuilt on VS2015 without errors.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Resolved the issue by saving the project elsewhere (not within the user directory path). Usernames with special characters seem to cause problems.

more ▼

answered Nov 23 '15 at 11:57 AM

avatar image

The Dark Enigma
46 1 2

avatar image Kallex Nov 23 '15 at 03:51 PM

I didn't have any special characters on my path, nor anything different on how the previous version worked (I'm not sure if I ran 4.9, but my version was at least 4.8). I'm proceeding to copy the project to different location (to avoid user-specific permissions) and retry.

avatar image Kallex Nov 23 '15 at 04:11 PM

Testing again from scratch; I'm assuming I have something legacy messing this up somehow...

avatar image Kallex Nov 23 '15 at 06:15 PM

My problems went away when starting from scratch apparently as well; saving in user specific directory but without any special chars.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question