x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Variable not found when starting game in Standalone Game

Hi guys,

I've got a little problem when trying to start my game via Standalone Game shortcuts. First of all these are my created shortcuts

Server:

 "[...]/UE4Editor.exe" "[...]/Tauri.uproject" ThirdPersonExampleMap?listen -game -log

Client:

 "[...]/UE4Editor.exe" "[...]/Tauri.uproject" 127.0.0.1 -game -log

I've got these settings from the YouTube videos about "Networking" uploaded by "UnrealEngine".

Source: https://youtu.be/TbaOyvWfJE0?list=PLazd85aC7SEduq626JeZIuUjAjVb6qRNt&t=526

Inside my game I've added variables to some of my C++-Classes. For one I added a FRotator-variable to my TauiCharacter.h:

 UPROPERTY(Replicated, BlueprintReadWrite)
 FRotator ViewportRotator;

and a TArray-variable to my TauriGameState.h:

 UPROPERTY(Replicated, EditAnywhere, BlueprintReadWrite, Category = Multiplayer)
 TArray<ACharacter*> playerPawns;

These variables are then used by Blueprints like this:

ViewportRotator inside my ThirdPerson_AnimBP-Blueprint: alt text

playerPawns-Array inside my TauriCharacterBP: alt text

When starting the game from within the editor as "New Editor Windoe (PIE)" it starts fine and no errors occur whatsoever. However when starting the game from the shortcuts mentioned above I get multiple errors such as:

 [2015.11.22-01.15.34:122][ 0]LogBlueprint:Warning: [compiler ThirdPerson_AnimBP] Warning Could not find a variable named "ViewportRotator" in 'TauriCharacter'.
 Make sure 'TauriCharacter' has been compiled for Get ViewportRotator

All warnings and errors inside the log can be found here: https://www.refheap.com/111962

What I've tried so far:

  • Re-Compile C++-Classes (from within the Editor)

  • Re-Compile Blueprints

  • Re-Adding Variables to the Classes

  • Re-Building C++-Classes (from within VisualStudio)

  • Restarting Editor

  • Restarting VisualStudio

  • Restarting Windows

I can't figure out what my problem happens to be. Does anybody know how to fix this issue?

Thanks Max

Product Version: UE 4.10
Tags:
more ▼

asked Nov 22 '15 at 01:19 PM in C++ Programming

avatar image

PT_Max
23 5 10 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I tried figuring this out for literally two days and then posted this question. Two minutes I've submitted the quesion I found the solution. VisualStudio was debugging in UnrealGame Editor instead of Development Editor. Changed it to the latter and the errors are gone.

more ▼

answered Nov 22 '15 at 01:34 PM

avatar image

PT_Max
23 5 10 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question