x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Reducing Resolution Scale in editor messes up actors selection in viewport

Branch: This is a 'Binary' build from the Unreal Launcher.

Build version: 4.10.0-2758231+++depot+UE4-Releases+4.10 (running on Windows 10)

Detailed description of the issue: I noticed when using for example 50% Resolution Scale in the editor (when simulating a game directly in the viewport) it will mess up the actors selection. I assume it's because of wrong conversion of the viewport mouse click coordinates to the down-scaled render buffer? You can easily see this in the editor in the map "Minimal-Default" from the UE4 StarterContent (although it's not a map related issue).

Repro Steps:

  1. Open the "Minimal-Default" map from the UE4 StarterContent of a new project.

  2. From the "Settings -> Engine Scalability Settings -> Resolution Scale" reduce the resolution to 50%.

  3. Click the "Play -> Simulate" option.

  4. Now in the viewport try to click to select a chair actor or table or ground and repeat this for various actors in the scene. You'll notice the click selection accuracy issues. When trying to select a chair sometimes the ground will get selected instead. If you change the "Resolution Scale" back to 100% you'll notice the selection accuracy is ok again.

The issue has a 100% repro-rate.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 22 '15 at 09:15 PM in Bug Reports

avatar image

florin.covit
91 3 6 58

avatar image hurt720 Oct 13 '17 at 08:33 PM

It has been two years, and this issue is more relevant now with 4k screens and a need to have a lower viewport resolution for playable framerates. Please reopen the ticket, thanks in advance.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey florin,

This is a known issue with UE4 that we have in our system as UE-5401. I've added your information to the report. We'll let you know if we see any update or if we require any additional information. Thanks for the report!

more ▼

answered Nov 23 '15 at 02:12 PM

avatar image florin.covit Dec 03 '15 at 09:12 AM

Thanks for the quick feedback! Great work!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question