x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't package project

Everything worked just fine, but then I decided to go through recommendations on reducing apk size for Android https://docs.unrealengine.com/latest/INT/Platforms/Android/ReducingAPKSize/index.html

And now build fails. I also tried to cook content for windows, and it also fails.

Can anybody help me in this? I have an almost complete project on my hands, which suddenly doesn't compile :(

The project is blueprint only.

[edit] Logs for android and windows build attempts are attached.android windows

Product Version: UE 4.10
Tags:
more ▼

asked Nov 23 '15 at 10:18 PM in Packaging & Deployment

avatar image

vnhllsng
159 5 12 149

avatar image Samantha Sutton ♦♦ STAFF Nov 23 '15 at 10:43 PM

Hey Vnhllsng,

Could you please provide me the packaging logs as a .txt file, one for each version you've tried to package.

Thank you!

avatar image vnhllsng Nov 23 '15 at 11:32 PM

Sure. I should've done that in the first place.

avatar image vnhllsng Nov 24 '15 at 12:31 AM

Also I can't set Build configuration to Development (File->Package project->Build configuration). The development option is inactive.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Could you please look over this AnswerHub post entirely and let me know if the information provided here corrects the mscorlib issue you're running in to?

Thanks!

more ▼

answered Nov 25 '15 at 07:55 PM

avatar image vnhllsng Nov 26 '15 at 09:47 AM

I got everything working again.

  • made a new empty project;

  • migrated all the content

  • imported some of the settings pages (like android build, inputs) and manually setup the rest (like maps&modes)

And everything is working now. I have completely no clue, what happened.

Earlier I was going to try the solution from the post you linked, but I didn't have binaries/windows/ in my project.

avatar image Samantha Sutton ♦♦ STAFF Dec 01 '15 at 07:47 PM

Thanks for letting me know how you got this to resolve. Please let us know if you run into any additional complications.

Have a great day!

avatar image polemos Jun 14 '16 at 04:31 AM

Samantha I am running into a similar issue, I went as far as doing the steps vnhllsng did, new project and migrating but I am still getting the results package failed almost immediately, can you take a look at my log and help guide me please?link text

outputlog.txt (10.0 kB)
avatar image polemos Jun 14 '16 at 04:38 AM

I am packaging to windows 32 bit and 64 bit I tried to package a blank project and it worked fine, I am attaching that log also don't know if that helps, also they are both started from Blank projects.link text

avatar image Samantha Sutton ♦♦ STAFF Jun 17 '16 at 09:46 PM

Polemos,

This is the issue that's seen within your logs: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015.

Please review this link for additional assistance, thanks!

avatar image TheLuffy_ Feb 14 '17 at 02:52 AM

hey my error is it exit code =1 do you help me please??

avatar image Samantha Sutton ♦♦ STAFF Feb 14 '17 at 05:43 PM

zVitor,

Please post your question in your own thread on AnswerHub. Please make sure you include the logs as a .txt file.

Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

How can i resolve this prob :(((

link text

build error.txt (29.5 kB)
more ▼

answered Jul 01 '16 at 11:31 AM

avatar image

Unakain
1 1 2

avatar image Samantha Sutton ♦♦ STAFF Jul 01 '16 at 05:16 PM

Unakain,

You might need to submit your own AnswerHub post if you're not able to resolve this issue.

Here is the error:

WARNING: ERROR: NOTE: Please ensure that 64bit Tools are installed with DevStudio - there is usually an option to install these during install

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question