x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Steam Api disabled

I tried getting Steam to work in my game, but I can't seem to get it right.

When playing as a standalone game it says that the steam api is disabled. When launching the game the errors as seen in the last picture appear. When building the game steam also doesn't work. (development build)

Below you can see my build, target.cs, defaultengine.ini, and steamworksbuild.cs
Click on the images attached so you can read them ^

I'm using the standard engine version, nothing from github.

Steam1 Steam2

Product Version: UE 4.10
Tags:
steam1.png (406.9 kB)
steam2.png (398.5 kB)
more ▼

asked Nov 24 '15 at 02:09 PM in Using UE4

avatar image

aondw
16 3 5 8

avatar image Jack Harmon Dec 07 '15 at 11:11 PM

I'm having the EXACT same problem. =\

avatar image Maide Mar 14 '16 at 09:48 PM

Do you by chance not have the Steam client open while you're launching your application?

avatar image Syrill Apr 25 '16 at 03:33 PM

I´m getting the same warning that steam is disabled, when packaging our project...

avatar image MAGtechnologies May 24 '16 at 02:46 AM

I have exact same problem in 4.11, had this in 4.10 but hoped it would be sorted in 4.11 now our game is on steam, this is very urgent. i raised a question last month about this and still dont get a reply.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

In my case the problem was that everything that has to do with UE4 and Steam has to be permanently running in admin mode, or otherwise it won't work.

If you use the steam setup utility and run everything in admin mode it should work fine.

more ▼

answered May 24 '16 at 04:51 PM

avatar image

aondw
16 3 5 8

avatar image Name368 Nov 26 '17 at 02:44 PM

+1, this worked for me.

ADDITIONAL CAUTION:

Im using on my PC user + admin account, but anyway, when i ran steam+powershell+unreal on my user account as admin (just everything as admin), it was not enough. I had to add admin privilegies from my admin to user account and then it worked.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is my setup on my DefaultEngine.ini. Out of the box, without modifying the engine, this works with the Steam Overlay, unless you are working with a c++ project, in that case, you have to do modifications on the solution. See Allar's blog, he explains it very clearly.

http://allarsblog.com/2016/02/26/BasicSteamIntegration/

Added: To make it clear, you dont even need to add any files into the Engine, unless you are planning on updating the SDK, if not...UE4 works with steam as soon as you add the setup into your DefaultEngine.ini (inside your project folder, not your Package Build folder)

[URL] GameName=Maze

[/Script/Engine.GameEngine] +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem] DefaultPlatformService=Steam

[OnlineSubsystemSteam] bEnabled=true GameServerQueryPort=27015 SteamDevAppId=480 bVACEnabled=0

[/Script/OnlineSubsystemSteam.SteamNetDriver] NetConnectionClassName=OnlineSubsystemSteam.SteamNetConnection

more ▼

answered May 24 '16 at 04:28 AM

avatar image

jblaswu
813 22 11 46

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I did this but now my project has stopped in this packaging step forever and does not want to come back any morealt text

more ▼

answered Jan 11 '18 at 09:56 PM

avatar image

TheSubZer0
118 8 14 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question