x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why is my level so shiny?!

After I built light, some of my materials began to become really shiny. I set the roughness to 1.0alt text

Product Version: UE 4.10
Tags:
capture.png (1.9 MB)
more ▼

asked Nov 24 '15 at 08:02 PM in Rendering

avatar image

SoraJr
263 61 52 66

avatar image Logan Bailey ♦♦ STAFF Nov 24 '15 at 08:15 PM

Hey SoraJr,

Could you post a screenshot of your materials that are now shiny. You could look into turning down the metallic or specular if you have them enabled. You could also disable bloom and eye adaptation in your viewport.

alt text

Logan

shiny.png (14.5 kB)
avatar image SoraJr Nov 24 '15 at 08:27 PM

If I set my bloom setting, in the post processing volume, intensity to 0. I get this. But it still has a glare that it never used to getalt text

Here's what the ceiling is made from, everything else that's shiny is pretty much made the same wayalt text

capture1.png (2.1 MB)
capture2.png (576.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It looks like it could be because of the correctedNormals node that you have. Are both of the normal maps changed to normals inside of your texture settings? Does plugging a normal directly into the normal channel eliminate that harsh light?

Logan

more ▼

answered Nov 24 '15 at 08:49 PM

avatar image SoraJr Nov 24 '15 at 09:14 PM

Thank you. Going into the texture settings for the normal and detail normal fixed it. For the normal, I changed the Compression settings to normalmap. The detail normal was already changed to that. I thought they were both changed because I got a message saying "converted to normal map" or something along those lines alt text

fixed.png (1.9 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question