x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Scale incorrect when exporting mesh from UE4

I wanted to create a replacement for the rocket launcher in the shooter demo so I exported the skeletal mesh to make sure I had the scale correct. Once it came to importing the new mesh into UE4, I found that it is more than 10X too big even though I exported the FBX from 3D Studio Max with the unit scale set to centimeters. My only thought on why this might be is that when exporting the original launcher out of UE4, the FBX didn't set the scale to centimeters. There's no option to adjust the scale manually.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 24 '15 at 10:47 PM in Everything Else

avatar image

TorQueMoD
1.2k 86 116 146

avatar image Jacky Nov 24 '15 at 10:51 PM

Have you changed units setting in export dialogue box of Max? Leaving it at Automatic should work just fine. Also dont forget to reset Xform > Convert to Editable Poly before exporting.

avatar image TorQueMoD Nov 24 '15 at 11:20 PM

Yeah that's what I said...

I exported the FBX from 3D Studio Max with the unit scale set to centimeters

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi TorQueMoD,

Jacky is correct. You will need to make sure to check your scale.

This needs to be set when Importing and exporting any mesh. You need to make sure that it's set to CM.

For comparison here is how I always make sure I'm working in the correct scale.

In Max I set my Home Grid to be 10cm and use CM as the default measurement scale (not just for export and import). I also setup a simple box as reference that uses uses the following values, xyz = 5, 5, 185

I use these values because 185 cm is ~6 feet tall.

With these values set you'll get the proper results. Since this isn't a bug with UE I'm going to move it out of bug reports, but I hope this helps you get setup. If you're still having trouble, post screenshots showing your scale setup, a scene with the hero skeletal mesh and a box mesh like I use setup for reference. Also the import/export window showing that the scale is set to CM.

Thank you!

Tim

more ▼

answered Nov 25 '15 at 06:05 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image TorQueMoD Nov 25 '15 at 09:03 PM

Thanks Tim. I actually do have max set up the same way that you suggested which is what led me to believe this was a bug. Apologies. What I didn't realize is that when importing an FBX it doesn't automatically set the scale based on the export options (I thought it would be hard saved in a specific scale) so when importing it was converting to millimeters for whatever reason and was scaling everything up by a factor of 5.

Problem solved. Thank you very much.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question