x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Zenfone 5 & UE4

Games that are made with Unreal Engine 4 crashes on splash screen since I uploaded my Zenfone 5 from KitKat to Lollipop. With my phone, I can play UE3 and Unity 5 made games well. But I can't play games that are made with UE4. Tappy Chicken, which is a 2D game is same. Considering this phone is still popular in many countries, I think a bug-fix for this phone is neccesary. I think, considering it can work well with UE3, it can also work with UE4. Maybe a little fix may clear this bug?

Here is the test video for Tappy Chicken, Sun Temple and Epic Citadel.

Thank you.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 24 '15 at 11:24 PM in Bug Reports

avatar image

SalihBalkan
424 15 28 58

avatar image Samantha Sutton ♦♦ STAFF Dec 01 '15 at 09:58 PM

Hey SalihBalkan,

Thank you for all of the information provided. Could you please provide me with the Monitor.bat logs. You should be able to find Monitor.bat at the following filepath, or one similar: C:\NVPACK\android-sdk-windows\tools

Looking forward to hearing back from you, thanks!

avatar image SalihBalkan Dec 03 '15 at 11:46 AM

link text Here is the log file that is created while Sun Temple with Unreal Engine 4.10 has been executed.

log.txt (53.5 kB)
avatar image Samantha Sutton ♦♦ STAFF Dec 03 '15 at 06:09 PM

Salih, did you try any of the helpful tips that were included in this post? The crash you're having looks like it's a GPU crash. Unfortunately, we do not have the Zenfone 5 to test on, we can only test on similar devices and we haven't seen this issue yet. Are you upgraded to the newest version of Android released on this device?

Thanks!

avatar image SalihBalkan Dec 04 '15 at 03:09 PM

I looked that page. That user said that returning at the first line of the "void InitDebugContext() {...}" in the OpenGLDevice.cpp solved the problem. I edited that file via notepad in this way:

void InitDebugContext()

{

return; // I ADDED THIS

...

Then I packaged the game again, but result is same with SunTemple & UE 4.10. Same level works properly on my LG L70 with KitKat and Samsung Galaxy A7 with Lollipop.

Yes I upgraded my device software. Before I have been updated my software from Kitkat to Lollipop, it was working fine. This is the latest version on the Zenfone 5 A501CG's official firmware page.

Model number: ASUS_T00J Software information: WW_3.24.40.78_20151001

avatar image Samantha Sutton ♦♦ STAFF Dec 04 '15 at 06:01 PM

Did you also look at Chris Babcock's response? He's our Android developer who has given tips on this thread as well. Could you please provide me with the updated logs?

Thank you!

avatar image SalihBalkan Dec 04 '15 at 08:07 PM

GitHub sources is needed for that solution. Now I'm downloading GitHub source and Visual Studio 2015. I will write the result here.

avatar image Samantha Sutton ♦♦ STAFF Dec 07 '15 at 05:09 PM

Please let me know once you've done so. Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey SalihBalkin,

Could you verify whether or not this issue has been corrected in 4.11 Preview 3? It's not advised to create games in preview versions of the engine however, if it's fixed in the preview that means it made it in for 4.11 whenever it does release.

Please let me know!

more ▼

answered Jan 29 '16 at 08:35 PM

avatar image SalihBalkan Jan 29 '16 at 10:03 PM

I tested it on 4.11 preview 1 and it worked.

Here is the log of Sun Temple that was packaged with 4.11 p1: http://pastebin.com/ah6NyrTH I thought that fixing a bug with support of only one user is a little bit hard so I sent the log to make you sure.

Also, I will test it on 4.11 p3 as soon as possible.

avatar image SalihBalkan Feb 02 '16 at 08:05 PM

Hi Samantha Sutton, Now I can verify that this issue has been corrected in 4.11 Preview 4. I tested it with 4.11 Preview 4 Vehicle template on Zenfone 5 A501CG and it is okay. Here is the log: http://pastebin.com/9ymGm7nZ

avatar image Samantha Sutton ♦♦ STAFF Feb 04 '16 at 05:56 PM

SalihBalkan,

Thank you for verifying this on your end as well. The issue has been closed out. Let us know if you run into anymore trouble! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
  1. I set up Visual Studio 2013

  2. I downloaded GitHub Source

  3. I added return; line to the begining of InitDebugContext() in OpenGLDevice.cpp

  4. I builded the engine

  5. I tried to package SunTemple again

  6. Builder crashed. I added empty C++ code to the project than it builded and packaged successfully. This is the solution on the internet, I don't know why.

  7. I packaged SunTemple

  8. Now it works fine on Zenfone 5 Lollipop :)

I am busy right now so I can't send the logs in this time, if you want it please reply. I will send as soon as possible.

more ▼

answered Dec 09 '15 at 04:40 PM

avatar image

SalihBalkan
424 15 28 58

avatar image Samantha Sutton ♦♦ STAFF Dec 10 '15 at 08:10 PM

Since you have resolved your issue, I will not need the logs. If you run into this issue again, please let us know and provide the logs then.

Good luck!

avatar image SalihBalkan Dec 11 '15 at 08:38 PM

Are you going to fix this on the next version of the engine? If you disable InitDebugContext for Zenfone 5, the problem will be solved. Can you please assign a bug code for this issue? Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I believe the problem is with glDebugMessageControlKHR in InitDebugContext(). For 4.11 we are now checking for GL_RENDERER to contain Rogue Han (one of the PowerVR chips) to disable this, but I may need to make it even more generic. The ZenPhone 5 has a fairly standard PowerVR 544, but it is likely the driver changed in Lollipop which is why you started having trouble.

Your log doesn't contain all the debug information I'd need to see what the GPU family returned by the driver is so I cannot see the version number.

If you could test reenabling InitDebugContext() but add the following to AndroidOpenGL.cpp in FPlatformOpenGLDevice::LoadEXT():

     if( !FAndroidMisc::GetGPUFamily().Contains(TEXT("PowerVR")) )
     {
         glDebugMessageControlKHR = (PFNGLDEBUGMESSAGECONTROLKHRPROC)((void*)eglGetProcAddress("glDebugMessageControlKHR"));
     }
 

So glDebugMessageControlKHR is not set (left NULL) if PowerVR, this might be the change I'll need to make in 4.11 to be safe. Please let me know and I'll see about getting it in for 4.11.

more ▼

answered Dec 14 '15 at 09:59 PM

avatar image

Chris Babcock STAFF
1k 11 110 35

avatar image Samantha Sutton ♦♦ STAFF Dec 15 '15 at 03:28 PM

UE-24501 has been entered to track this issue. Salih, please let us know your outcome from the steps Chris provided above.

Thank you!

avatar image SalihBalkan Dec 15 '15 at 09:51 PM

Hi Chris, as you said, I reenabled InitDebugContext then I added your code to the beginning of FPlatformOpenGLDevice::LoadEXT():

But it crashed in the same way before I had disabled InitDebugContext.

Monitor.bat log is in this link: http://pastebin.com/f20Kcuxi

avatar image Chris Babcock STAFF Dec 15 '15 at 10:56 PM

You did make sure glDebugMessageControlKHR is only inside the if? Okay, then there may be another call in InitDebugContext the driver doesn't like.

I don't have a Zenfone 5 so it would be very helpful if you could add some logging in InitDebugContext() before and after each of the gl calls so we can see which call it is crashing on.. just need to do something like this:

FPlatformMisc::LowLevelOutputDebugString(TEXT("Calling glDebugMessageCallbackARB 1")); ... FPlatformMisc::LowLevelOutputDebugString(TEXT("Called glDebugMessageCallbackARB 1"));

with a unique number on each so we can see how far it gets.

avatar image SalihBalkan Dec 16 '15 at 12:00 PM

Ah sorry I misunderstood you. Now I covered glDebugMessageControlKHR with the if statement that you gave. I will try again rebuilding by combining both of your suggestions and give you the results as soon as possible.

edit:

I covered glDebugMessageControlKHR line with if statement in AndroidOpenGL.cpp, then it worked fine. I tested with SunTemple and it looks OK.

FPlatformOpenGLDevice::LoadEXT() -> pastebin.com/mUspFqzZ

InitDebugContext() -> pastebin.com/BJZ6mGJq

Monitor.bat log -> pastebin.com/n6wyHywh

avatar image Chris Babcock STAFF Dec 16 '15 at 05:30 PM

Thank you, this is what I was expecting. I'll get this into 4.11.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question