x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal will not recognize my Android Device

I cannot get my editor or unreal device manager to see my phone (galaxy S6) so I can't deploy my app to it... It worked at one point in time, but my project settings didn't have the android SDK configured correctly so the deployment would fail. Now that I have entered the correct directories for the android SDK, I can't get the device manager to see my device so I can TEST that the deployment is working correctly. The phone is being seen with ADB, and it is in debug mode. I have tried setting it to MTP and PTP with no luck. Is there anything else I should try?

Thanks!

Product Version: UE 4.10
Tags:
more ▼

asked Nov 25 '15 at 01:37 AM in Packaging & Deployment

avatar image

USMC1812
26 5 12 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi USMC1812 -

I think this might be an issue with your Environemnt Variables being set incorrectly.

Try reviewing this section of documentation and setting the varaibles and see if Unreal can then see your phone.

https://docs.unrealengine.com/latest/INT/Platforms/Android/Reference/index.html#environmentvariables

Let me know if this does not correct your issue -

Eric Ketchum

more ▼

answered Dec 02 '15 at 09:37 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.6k 703 260 737

avatar image USMC1812 Dec 03 '15 at 03:41 AM

OK I Finally got it to see my device again thanks to your help! All of the environment variables were set correctly, so I tried removing the paths for the Android SDK in the unreal editor project settings. I closed everything, then opened the editor again and set them again, just like the Environment variables for the system. I closed everything again and opened the editor one more time and now it's showing up. I'm not sure what exactly went wrong the first time I did it, but that seems to have fixed it. Thanks for all your help!!!

avatar image Raptagon Studios Apr 22 '18 at 12:13 AM

We are also getting the same issue, but removing and adding the SDKs is not working for us. We still can't see either of our phones in Unreal Engine even after enabling developer options.

avatar image thenegaverse May 19 '18 at 06:14 AM

Installed SDK, went through the Android Startup Documentation using UE 4.18, updated to 4.19 to see if that was the problem, reinstalled SDK, fresh third person template project according to walkthrough, and still nothing. Then I went into the Android SDK tab in project settings, deleted the four paths to the SDK folders and now it's working for my brand new Samsung Note 8 lol wtf? Thanks for the tip cause it worked haha.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question