x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my Skylight not showing/updating up when I choose set new time on my timeline?

I have a day/night cycle Blueprint currently set up using a timeline controlling my sunlight and ambient (Skylight) light. On my timeline "0" is midnight and it is 900 seconds long, making it a 15 minute long day cycle. My lights are all set to movable and I have my skylight set to cast no shadows because I just need it to keep my scene and shadows from being too dark. I have floats and color tracks in the timeline for light intensity and color of each light.

So if I start the timeline from 0 the whole cycle works great and my lights update as necessary. If I choose a new time on the timeline and start from a new time the skylight does not seem to update visually but according to my string being printed it does show the intensity updating correctly.

If I start the timeline out before 190 seconds, which is just before the sunrise then the skylight seems to never put out any light... ever. If I start around 195 then the skylight is putting out light and seems to work...

My whole point for setting a new time is for when a saved game is loaded, the time of day is accurately set for when the game was saved.

Any thoughts?

Product Version: UE 4.8
Tags:
more ▼

asked Nov 25 '15 at 03:40 PM in Blueprint Scripting

avatar image

Overwatch04
321 22 20 32

avatar image soTaddel May 17 '17 at 04:17 PM

Same problem here. Is there any fix yet? Do I really have to set the itensity on Begin Play (this is my hotfix)?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

This may not be the best fix but I found that if put a 1 second delay before I send the new time float then it works... May be a timing issue somewhere??? I would like to still leave this open for discussion for an actual solution instead of a band aid.

more ▼

answered Nov 25 '15 at 07:54 PM

avatar image

Overwatch04
321 22 20 32

avatar image Alwaysusa Sep 29 '17 at 06:40 AM

This worked for me, so thank you. Old question I know :)

I added a delay of 0.1 seconds after the timeline had started, then set the new start time - problem solved. The skylight intensity renders correctly.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question