x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rename blueprint changed nothing in project settings

I've renamed a blueprint in the content browser and compiled the game. Then i've started the game, the game crashed and the log showed me that the old blueprint name couldn't be found. The project settings told me that the now the default (gamemode/playercontroller/etc...) is now active, but then i wouldn't recieve the error.

Renaming the blueprint should change the setting in the project settings too, and if the blueprint in the project setting couldn't be found a error should be shown and not the default value.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 25 '15 at 04:15 PM in Bug Reports

avatar image

DARK-ELITE-BOSS
1 1 2

avatar image Shadowriver Nov 25 '15 at 04:30 PM

I gonna move this to Bug Raports as... it sounds like bug raport ;p

avatar image DARK-ELITE-BOSS Nov 25 '15 at 04:31 PM

thats right. Clicked on the wrong category

avatar image Sean L ♦♦ STAFF Nov 25 '15 at 06:45 PM

Hello,

I have attempted to reproduce your issue by renaming a blueprint in the content browser and then attempting to run the game. However, I was not able to experience a crash. Could you provide the steps that you took to experience the crash so that I can ensure I am following them correctly?

Also, could you provide your Machine ID from the Crash Reporter window and ensure that you send the crash report?

Thank you.

avatar image DARK-ELITE-BOSS Nov 26 '15 at 11:00 AM

Machine id: 569B142A4BC5FAA3F3AD1CB0A034E1EE Found 2 problems:

  1. After cloning a project only the gameinstance is set correctly.

  2. Only renaming the gameinstance causes the crash: I've changed the nameof the gameinstance. In the project settings is the correct new gameinstance name displayed. Then packaged the projact as development Windows 64bit. Running the packaged game causes a crash. Play in the editor causes no crash, but launch in Editor does.

After changing the gameinstance to default and back the game launches

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

I have looked into your issue and discovered that it is already a known issue in our system (UE-6040). Thank you for your report.

Have a great day,

Sean Flint

more ▼

answered Nov 27 '15 at 03:30 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question