x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my light affecting only certain meshes on baking?

I've just started to learn about Lighting in Unreal, and for that I've added a Point light with extended Length and Radius in one of the corners of a map I'm working with. It's a static Light, I don't really care about the shadows it needs to cast. Before baking in the Lighting, I see what I expect to see - alt text

After Building my Lighting, One of the meshes plus the landscape below seem to be pretty devoid of any lighting effect whatsoever. Like so - alt text

Any hints as to what I could be doing wrong?

Product Version: UE 4.9
Tags:
01.png (1.4 MB)
02.png (1.3 MB)
more ▼

asked Nov 26 '15 at 07:38 PM in Rendering

avatar image

daniyalmirza
8 4 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello daniyalmirza,

What you see before baking lighting is a preview meant to show you the editors best guess at what your lights will look like after building.

There are a few things you can do in order to get the most accurate lighting build that should reflect what you see in the editor.

  1. When you build your lighting, if you click the down arrow next to build, a drop down menu will appear that has the option for lighting quality. Make sure this is set to Production. This will ensure that the most accurate sample of lighting will be taken through raytracing. This will affect your build times but will give you the best result possible.

  2. You could try changing the light to stationary. This allows for elements of fully baked, or static lighting, and fully dynamic, movable, lighting. This means that certain options are now available that are not available in fully static lighting. I.E. cascade shadow maps. This allows for a distance calculation of how far your shadows are calculated, how many samples are taken and so on.

  3. The last thing to consider is the resolution of your lightmaps on the objects you are baking your lights on. You can check this by going to the object in your details panel. For example, the floor that the shadows from the pillars you have in your scene are being cast on. Double click on this object, in your details panel, to bring up the details of that mesh. On the right side you will see a section called " Static Mesh Settings." In that section there is a tab called Light Map Resolution. You may play around with the values and try increasing them. They act much like texture map resolution so values of 2 ranging from 128, 256, 512 and so on.

After troubleshooting with these three steps you should see a vast improvement in the accuracy of the lighting within your scene.

Logan

more ▼

answered Nov 30 '15 at 06:47 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question