x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Runtime Navmesh Generation not Working?

Hey guys,

I've set "Runtime Generation" to Dynamic and the "Force Rebuild on runtime" is also checked. But the navmesh doesn't update during runtime when I change the mesh of an actor.

If I restart PIE then the navmesh is generated properly as expected.

I've also tried the execute console command "RebuildNavigation" in my BP, but this doesn't work.

How can I fix this?

Thanks.

Product Version: UE 4.10
Tags:
more ▼

asked Nov 27 '15 at 06:53 PM in Using UE4

avatar image

Amaresh
208 29 35 44

avatar image Amaresh Nov 28 '15 at 09:20 PM

Can Anyone help me with this?

avatar image CodyScrib Dec 03 '15 at 05:19 AM

I have nothing to help you with but im having the exact same problem. I want to spawn meshes that you can walk on after the game has started and the nav mesh just wont build. Ill let you know if i come up with anything. If nothing else perhaps this will bring attention to the issue.

avatar image Amaresh Dec 03 '15 at 08:55 PM

Hey CodyScrib,

I've finally got it to work. As @mieszko suggested in his answer, Navigation mesh only detects change in the world if you spawn a new object or actor into the world.

So, I just went ahead and did that and it works perfectly.

Create a static mesh actor and spawn that at runtime. Or you can create a static mesh actor variable and assign the static mesh to it after spawn.

It worked for me. Hope it also does for you.

Thanks.

avatar image CodyScrib Dec 03 '15 at 09:11 PM

Thanks for the reply! i changed my meshes from instanced to just the regular old static and it still doesnt build to the spawned meshes. I have the Runtime generation set to dynamic, is there anything else you changed. any other setting i could be missing?

avatar image Amaresh Dec 03 '15 at 09:14 PM

have you checked the Force Rebuild on runtime option. And also check the collision on your mesh.

avatar image CodyScrib Dec 03 '15 at 09:24 PM

Yep Force Rebuild is checked. I assume the collision is correct. If i through the mesh in just regular from the Content Browser in to the Level then it builds nav to it but if its spawned in it doesnt build however I noticed that it does rebuild in some small areas occasionally. So it is building during runtime. Just not to the spawned meshes

avatar image CodyScrib Dec 03 '15 at 09:31 PM

Actually navigation just stops building when I simulate

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'mt pretty sure runtime mesh changes won't rebuild navmesh. Forcing rebuild won't help neither, because navigation system simply doesn't know anything about the change. I suggest changing the mesh differently, like adding new static mesh component, or spawning new actor altogether.

Cheers,

--mieszko

more ▼

answered Nov 29 '15 at 01:21 AM

avatar image

MieszkoZ STAFF
7.3k 223 57 412

avatar image Amaresh Nov 29 '15 at 01:36 AM

Hey mieszko, thanks for replying.

I'm changing the current mesh by set static mesh. You are saying that it won't get recognised by the navmesh as a change? Is that correct?

My actor contains a lot of components, so spawning the entire actor just to change a single component doesn't seem right to me. I'll do it if there isn't any other solution.

Can you suggest any other solution to this?

I've also tried setting the collision after changing the mesh.

Thanks

avatar image Amaresh Dec 03 '15 at 08:58 PM

Ok @mieszko. I went ahead and spawned the required static mesh actor as you suggested and it works.

But, It would've been great if changing the mesh is detected by the Navmesh instead of spawning it. Just Saying.

But thanks anyways. Cheers.

avatar image MieszkoZ STAFF Dec 03 '15 at 11:47 PM

Yeah, it would, I know. We'll get around to fixing it at some point, I promise.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question