x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Multiplayer Blueprint Project - Failing to Package

Hey,

We have been working on a MP Blueprint Project, its currently based on the MP Shootout game modeand uses the same widget/blueprint system.

We integrated Steam via the .ini files and it works perfectly in the editor and standalone game mode.

However it packages and cooks successfully but upon boot it will instantly crash and display no bug or error code, claiming I don't have the symbols to view it.

I will attach the logs in a .rar file so they can be accessed, and hopefully someone can shed some sort of light on the matter.

Crash Logs

Error Log

Product Version: UE 4.10
Tags:
more ▼

asked Nov 28 '15 at 01:07 PM in Packaging & Deployment

avatar image

Nemecys
90 11 18 219

avatar image Nemecys Nov 28 '15 at 03:56 PM

I have narrowed the issue down to my .ini files and its definitely related to the Steamworks implementation.

I have tried to go through the OnlineSubsystems doc but to no avail, the file locations are a big vague and hard to locate the .cs files and im unsure as to whether i actually need to edit them or not; due to the my game being entirely blueprint based.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

https://answers.unrealengine.com/questions/50259/steamworks-failing-to-find-dlls.html

Managed to fix it with a combination of this and the Doc's page, Im not sure if i had to install VS2015 for this or not.

However i did create a C++ file in the project to edit the games build.cs and target.cs files, but i am not 100% sure that was what fixed it, I had some compile errors with some poorly referenced files.

That could of possibly caused the crashes with an incorrectly labelled game instance file.

more ▼

answered Nov 28 '15 at 08:58 PM

avatar image

Nemecys
90 11 18 219

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question