x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

WidgetDebugger not showing variables in scope.

The boolean is public in the GameMode BP

Bigger Picture

I also can't read any floats as well. It's all Public. Other blueprints have no problem accessing these variables.

Steps to reproduce: Make a public variable in the event graph of a game mode. Then access it from a UI Widget BP. Debugging during runtime will show it out of scope, however all functions will be resolving.

Even if cast every tick, still out of scope.

PS: I didn't recognize this as a bug and thought that I was somehow at fault. I asked a question, but now I can't change the category to a bug report. Please delete it. >Link<

Edit: Ok, it seems that it doesn't matter if the variable is in scope or not. I have the same thing happening to local variables as well. This only happens in widget debugger.

How?

Product Version: UE 4.10
Tags:
more ▼

asked Nov 28 '15 at 07:00 PM in Bug Reports

avatar image

Kensei
84 18 23 22

avatar image Adam Davis STAFF Dec 01 '15 at 08:37 PM

Hi Kensei,

  • Is this widget a 3d widget or a normal widget?

  • Does this occur with any other variables or is it only local variables and variables called from other blueprints?

  • What steps can I take to reproduce this on my end?

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

avatar image Kensei Dec 07 '15 at 05:01 PM

Sorry for the super delayed reply Adam.

It's a normal widget I've only tested this with local and outside variables. To reproduce make a new local variable for a widget. (or outside var and call it in the widget). Happens in every project I have. Tried in blank, same result.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Kensei,

Local variables showing as out of scope in any blueprint is a known issue, and is currently in our system as UE-2821. I am going to update the bug report to reflect that this is affecting widget blueprints and that additional developers are experiencing this error.

more ▼

answered Dec 07 '15 at 06:21 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Kensei,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Dec 07 '15 at 04:11 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question