x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Retargeting UE4 to Mixamo not working properly

I have created a model, rigged and added animations with the use of Mixamo Fuse, which was super simple to import and use in UE4. However, retargeting animations from the UE4 Mannequin skeleton does not work properly for me. The skeleton seems to be exactly the same.

This is my model:

My Model

I need this animation from the UE4 skeleton:

Aim Offset

I use the retargeting service, which was made available in 4.5 I believe, but with a weird result: Weird

Changing the Bone Translation Retargeting Mode from Animation to Skeleton makes the mesh look normal, but messes up the animation.

Retargeting Mode Retargeted Mode

I have no clue what to do, I spent 4-5 hours last night trying to fix this problem. With a different animation I tried to just adjust it myself, but that brings on whole new problems. I know some people have had the same problem, but I haven't found a solution for it yet. I hope someone can shed some light on this - perhaps it's a bug that needs fixing?

EDIT I have also done the Setup Rig and everything is exactly the same (not my picture, just showing function):

Setup Rig

Product Version: UE 4.9
Tags:
more ▼

asked Nov 29 '15 at 08:18 PM in Everything Else

avatar image

Busymonkey
25 4 4 9

avatar image Busymonkey Dec 13 '15 at 11:39 AM

Bump - Still need this :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I fixed it!

I just exported the Aim_Space_Ironsight animation from the Animation Starterpack and imported it again with my Player_Skeleton chosen - and voila!

alt text

more ▼

answered Dec 13 '15 at 12:00 PM

avatar image

Busymonkey
25 4 4 9

avatar image _cDub Dec 15 '15 at 03:02 PM

His thumb still looks a bit broken. :P Did setting the bone translation fix that?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just to comment on this as I ran into same issue.

Export the animation, then reimport to the specific skeleton. If you get any issues with deformation select 'show advanced settings' in the animation and then play around with the dropdowns of the affected areas. Switch between animation and skeleton to see the different results.

alt text

more ▼

answered Jan 10 '16 at 08:44 AM

avatar image

Joshua_NZ
138 7 13 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question