x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Disabling Indirect Lighting on foilage

how can i disable indirect lighting on foilage and only use at my static architectural meshes?

Product Version: UE 4.10
Tags:
more ▼

asked Nov 30 '15 at 09:41 PM in Rendering

avatar image

alperenozgur
18 4 11 18

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello alperenozgur,

You can choose disable the indirect lighting samples by selecting the meshes they will affect and in the lighting option change the drop down next to Indirect Lighting Cache Quality to ILCQ Off. This requires the mesh to be movable though. Also, this is only valid with static mesh's that have been placed manually inside of the level. With foliage a lighting cache is calculated for the foliage group that is created when utilizing that system.

Alternatively, if you don't want the light to cast any Indirect Lighting you can always disable it in the light source by setting the Indirect Lighting Intensity to 0.

There is no way, currently, to disable indirect lighting on foliage at this time.

Logan

more ▼

answered Nov 30 '15 at 10:09 PM

avatar image alperenozgur Nov 30 '15 at 10:20 PM

thank you for fast answer. actually my problem is foilage gets desaturated after lighting build. i discovered that if i disable "indirect lighting cache" at visualize they look as they should be. and lightmass importance volume doesnt working, they still get desaturated. anything i can solve this?

avatar image Logan Bailey ♦♦ STAFF Nov 30 '15 at 10:42 PM

If you would link me a screenshot of before and after your lighting build so that I may get a better understanding by what you mean when you say " desaturated. "

Logan

avatar image alperenozgur Nov 30 '15 at 11:04 PM

This is before and after i disable Lighting Features > Indirect Lighting cache. Some foilage got effect of that desaturation and some dont as you can see.

alt text

and this is after i disable lighting cache

alt text

avatar image alperenozgur Dec 01 '15 at 11:20 AM

no clue?..

(comments are locked)
10|2000 characters needed characters left

Hello slperenozgur,

Please refrain from bumping and inquiring about your issue.

Indirect lighting is an all or nothing feature. You can disable it, dim it, and change it's intensity. However, there is not a light linking feature that will allow you to pick and choose what you want to disable lighting on.

Logan

more ▼

answered Dec 01 '15 at 02:45 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question