x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

System cursor changing fail

Hi! I made simple things to change system cursor from arrow to hand. So when I'm pointing to one (door with cloth) object everything is fine, but on the same location when i'm pointing to another object (wardrobe) cursor doesn't want to change, while during debugging it shows that nodes are firing well. I'm using the same nodes and over cursor events in both objects. Probably I'm doing something wrong, any advice needed. Thanks!

finecur

wrong cur

bp

Product Version: UE 4.9
Tags:
fine_cur.jpg (51.1 kB)
wrong_cur.jpg (57.1 kB)
bp_cur.jpg (129.6 kB)
more ▼

asked Nov 30 '15 at 09:50 PM in Bug Reports

avatar image

Kajemyaka
13 3 4 8

avatar image Rudy Q ♦♦ STAFF Dec 01 '15 at 02:02 PM

Hello Kajemyaka,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you elaborate on what the mouse is supposed to be hovering over as shown in your screen shot?

avatar image Kajemyaka Dec 01 '15 at 06:47 PM

Hello Rudy! Thanks for answering! I tried to reproduce this issue in 2d platformer template, and unfortunately wasn't able to make it) What I did there is just made one actor with cube and collision box in it, and adjust collision box like this:

collision box

And it worked fine, when i'm hovering either box or cube cursor changed to "hand".

game

bp

Actually the same things I made in my main project. I'm using collision box to check what cursor to set. And one more thing: for example I made "door" to another room, it's an actor with just collision box in it, when mouse hovers it cursor should change to hand, when I'm clicking it we are going to another location. When I just made this actor everything was fine, but as I played a little changing cursor stopped working. I'm sorry for little information I can provied.

avatar image Rudy Q ♦♦ STAFF Dec 02 '15 at 02:54 PM

I noticed that you said you were unable to reproduce this in a clean project. Would it be possible for you to provide the project that is having the issue?

avatar image Kajemyaka Dec 04 '15 at 11:06 PM

Yes, sure, thanks! ) You can take development build from here: https://yadi.sk/d/idptN8AGkz5w8 And source project from here: https://yadi.sk/d/0B_Cdrebkz5xQ

avatar image Rudy Q ♦♦ STAFF Dec 08 '15 at 02:19 PM

Hello Kajemyaka,

I tried to access the projects provided however the links in your last post did not appear to work. Could you provide the project via google drive or drop box?

avatar image Kajemyaka Dec 09 '15 at 12:49 AM

Ooops, I'm sorry about that. Development package here: https://drive.google.com/file/d/0B3yi44afMY5RZnBfNU9iZHBXb0U/view?usp=sharing

Source of project here: https://drive.google.com/file/d/0B3yi44afMY5RSUNRWUxtYklQOXM/view?usp=sharing

And one more thing I wanted to add about this cursor failing: I've noticed that it works fine when I'm hovering an object that was last modified. As I wrote above: I had two objects (actors) 'door' and 'wardrobe' so if I just rename collision box component in any of them, that actor which was modifed the last will be working fine.

avatar image Rudy Q ♦♦ STAFF Dec 09 '15 at 04:04 PM

After looking through your project I have a test I would like for you to try. Could you please try going into your "DoorToKladovka" blueprint and enabling input from the player controller?

avatar image Kajemyaka Dec 09 '15 at 05:51 PM

Hi Rudy! Thanks for helping! I did as you advised, but unfortunately it didn't work. Or I'm missing something?

bp

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I took another look at your project and I did a bit more testing. I was able to find that your issue appears to come from the fact that you are setting the cursor on tick. I removed this from both the "DoorToKaldovka" and "Shkaf" and instead I used the setup provided below. I hope that this information helps.

Setup:

As you can see I removed the tick that was being used for this part and I have used the mouse over events to set when the mouse changes.

alt text

Make it a great day

setcursorhelp.png (172.2 kB)
more ▼

answered Dec 09 '15 at 07:44 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

avatar image Kajemyaka Dec 09 '15 at 08:14 PM

Thanks a lot that realy works! :) But I can explain why I used tick event. For example my character is away from the door, so I'm clicking on that door and while he moves to it I'm hovering the door, and when he get close to it and the cursor has to change it doesn't. I need to move cursor out of the collision box and then move it back to get right cursor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question