x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can not connect to Epic Servers

Hey everyone,

So here's the thing that I have been stuck on for the past two weeks trying to figure it out. The error I'm getting is that my launcher cannot connect to Epic Servers at all. I have uninstalled it (multiple times) / restarted my computer after doing it, I've added the -OpenGL and -http=wininet at the end of the target path, I have disabled my firewall then tried to run it (still didn't work), and I have ran it through my Windows Defender firewall, and I have turned off my VPN. Still nothing. I have asked the professors at my college and fellow classmates who are knowledged in UE4 and they all said that the things I've done should have worked and are baffled that it still doesn't. So please tell me that I'm not the only one with this problem. I am also in Windows 10, i don't think that is the problem but who knows. alt text

Product Version: Epic Games Launcher
Tags:
ue4.png (61.3 kB)
more ▼

asked Dec 02 '15 at 10:17 PM in Installation & Setup

avatar image

Dusty D
1 1 2 3

avatar image ModernRyoga ♦♦ STAFF Dec 03 '15 at 09:10 PM

Hi Dusty D,

I'm sorry to hear that you are having trouble. Are you attempting to connect to the servers through your own network or through the university network?

Just to verify, please make sure you've tried all the troubleshooting steps here.

If you have a firewall in place, please allow the following exception:

xmpp-service-prod.ol.epicgames.com port 5222

In addition, you may want to review this post as well.

If nothing works, follow the steps here to generate your Debug Logs. Post them here, along with your Dxdiag/system specs.

avatar image Dusty D Dec 09 '15 at 10:52 PM

Hello, First i would like to apologize for getting back to you so late. I'm a full time student and Finals are next week so these past couple weeks have been catching up on Homework. But I have tried all the things that you have suggested and still nothing. I believe this is a pickle.link text

debuglogsstoof.zip (246.1 kB)
avatar image Dusty D Dec 09 '15 at 10:56 PM

alt text Also here is a picture to help "visualize" what my stuff looks like. I hope it helps.

ue4stoof.png (678.2 kB)
avatar image ModernRyoga ♦♦ STAFF Dec 10 '15 at 05:48 PM

Hello again!

Based on your IP, it appears that you might be connecting through a university network, is that correct? If so, it's possible that the network admins have the specific ports blocked. Is anyone else able to connect from your location, either through the same wireless connection or hardwired port you are using?

avatar image Dusty D Dec 11 '15 at 06:29 PM

Yes that is correct but all the computers in my classroom have Unreal Engine installed on them (I'm in the gaming degree) so I don't think that that happens to be the problem as they all can connect properly. :(

avatar image ModernRyoga ♦♦ STAFF Dec 14 '15 at 06:24 PM

Hello again,

Interesting. And you are connecting through your classroom? Through the same data jacks that lab computers are using? I just want to verify that the require port(s) aren't open for just the lab computers.

avatar image Dusty D Dec 19 '15 at 05:39 PM

Unfortunately I was not, I was mainly connecting through WiFi, but I did try going straight to Port, but it still didn't work. I am at home now on Christmas break so I am going to try to "redo" all these steps again and see if it works.

avatar image ModernRyoga ♦♦ STAFF Dec 21 '15 at 08:53 PM

Hi Dusty,

Yes, please keep me updated. Another option is to try and flush your DNS cache. Normally this happens automatically, but at least one user has reported that this helped with his connection. To do this:

  • Open a Command Prompt

  • At the command prompt, type: ipconfig /flushdns

  • Reboot your system.

avatar image Dusty D Dec 23 '15 at 09:42 PM

Hey there again,

Unfortunately I did uninstall UE again, re-installed it and redid all the previous steps as before, but I am still getting the error. It seems to me that its not even attempting to connect to the "server", but this just could be me imagining things. I am including the new diag logs and other stuff needed. I did clean my DNS stuff and it seemed to work but it quickly "kicked" out.

Dustin.link text

egldebugstoof.zip (98.4 kB)
dxdiagstoof.txt (89.2 kB)
ue4stoof.png (410.5 kB)
avatar image ModernRyoga ♦♦ STAFF Jan 04 '16 at 09:52 PM

Hi Dusty,

I notice a couple things. According to your logs, the launcher isn't being run as admin. Try right clicking on it and choosing "Run as Administrator." Also, your paths for your program are showing "\" as different ascii characters. Is this an issue you have with all shortcuts and programs?

Do you have any sort of proxy software or network monitoring software running?

avatar image Dusty D Jan 05 '16 at 11:27 PM

i tried running it as an admin and it still did not work, as for the proxy software / network monitoring stuff, to my knowledge i have no such thing running in the background.

avatar image ModernRyoga ♦♦ STAFF Jan 08 '16 at 08:38 PM

Hello again Dusty!

Your issue has been reported as JIRA OPP-4968. I'll post back to you once I have more information.

avatar image ModernRyoga ♦♦ STAFF Feb 22 '16 at 06:31 PM

Your issues is still being investigated. If you are able to check, do the lab machines require you to log in are are they being accessed in "offline mode"?

Are you running Bit Defender Total Security by any chance? Could you also verify that Wndows firewall has been disabled if you are running another firewall software? Steps on how to do that can be found here.

avatar image LostScout Jan 04 '16 at 09:58 PM

I am having this exact same problem. Unity`s launcher also fails to connect. It has been going on for two weeks now. I am on windows 7.

avatar image Dusty D Jan 05 '16 at 11:27 PM

dude same here! i tried using my unity as well to see if i could work a little on that, but i have the same problems!

avatar image HealthHazard Jan 05 '16 at 08:46 PM

I am having the same issue. Whenever I try to log in to the launcher I get "Connection to server failed".

avatar image Dusty D Jan 05 '16 at 11:27 PM

Yep, this is what my life is revolving around now. llol

avatar image LostScout Jan 06 '16 at 12:02 AM

haha, I definitely understand your frustration. I am pretty sure it is the computer I am working on at this point, since unity is also not working. I am even unable to connect to nvidia to download my latest driver. lol

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Dusty,

We haven't heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you're still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.

more ▼

answered Mar 10 '16 at 09:29 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
more ▼

answered Feb 25 '16 at 04:27 PM

avatar image

LostScout
135 18 28 35

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question