x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

I can't get git(hub) to work with Source Control

So my (small) team and I need to use Source Control to run effectively as a team. We decided on GitHub and I downloaded the Github Desktop client. Everything went smoothly, I already had a project in Unreal so I built a new repository in the folder using GitHub Desktop and committed the all changes. I then launched Unreal and tried to use the included beta Git plugin. I put in the git.exe directory (took forever to find lol) and then I got a weird error message: "Failed to enable Git Source Control: you need to initialize the project as a Git repository first". I'll admit, I'm a complete noob when it comes to Git (which is why I chose to use GitHub Desktop since it has a UI), but I thought I had just done that...

So after all that, I thought my worst fears had come true, that I'd have to use Git instead. So I deleted the repository from GitHub Desktop, and the .git folder from the project folder and downloaded and installed Git. I fired up the Git and navigated to the project folder (it made miss Linux a little) and ran "git init" and "git add .". I then when to Unreal and tried again. Same error message. I was then struck a mixture with relief that I could actually use GitHub Desktop and frustration that this isn't working. (I know, as a developer, I should be used to the feeling...)

After hours off googling and reattempts including creating new UE4 Projects and Git repos, I gave up and decided to ask the wonderful people of AnswerHub.

Product Version: UE 4.10
Tags:
more ▼

asked Dec 03 '15 at 09:08 AM in Using UE4

avatar image

plmj1
6 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question