x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Prerequisites error E-1223 - could not install

Hi!!! I´m trying to install Unreal Engine 4.10 , the first one on this machine: (2.8GHz, W7- 64 bits, 4GB ram, 1GB video card. The download is ok, but when the installation process finishes "prerequisites", one error message appears and say:

Install Failed The necessary prerequisites have failed to install. Error code R-1638

.... Reading questions and its answers at Answerhub, I already had installed: Visual Studio Interprise 2015 with Update 1 Visual Studio Professional 2015 with Update 1 Microsoft Visual C++ Redistributable (X86) 2012, 2013 and 2015 Microsoft Visual C++ Redistributable (X64) 2012, 2013 and 2015

Windows 7 is up to date.

How can I do??? Thanks!!! ;)

Product Version: UE 4.10
Tags:
more ▼

asked Dec 03 '15 at 10:27 PM in Installation & Setup

avatar image

JBN2171
71 1 3 5

avatar image RamnGames Dec 03 '15 at 10:39 PM

Same issue, I have resumed and re-installed multiple times, also copies someone else's files and tried verifying that, but keep getting the same error.

Would love to know a fix!

avatar image JBN2171 Dec 04 '15 at 02:08 AM

Hi!!! Just follow the Tardygrade´s procedure, uninstalling Microsoft Visual C++ 2015 (X64) and (X86). After this, run the Epic Games Launcher again.

Note: when the shortcut was created in my desktop, it was connectet to EpicGamesLauncher Win 32.... so, up une level for directories and choose the Win64 version!!!

search for Epic Games / Launcher / Portal / Binaries / Win32 or V64...

avatar image RamnGames Dec 04 '15 at 10:19 AM

Thanks! I'm working on trying out the fix right now, reinstalling takes a bit of time :p but I hope it works!

avatar image JBN2171 Dec 03 '15 at 11:12 PM

I really don´t know if work with only 4GB Ram is the reason of this problem. And more, the error name alternates: sometimes E-1223 and sometimes R-1638... Would love to know how to fix too!!

avatar image tardygrade Dec 03 '15 at 11:15 PM

Same problem. Not RAm - 16gb here, so definitely not an issue. Getting the error about not being able to install prerequistes. I am using VC2014 but do have VC++ 2015 redistributable components (I just saw them in control panel / programs and features). Tried both on windows 8 and windows 10 - no luck

avatar image RussEarwaker Dec 15 '15 at 04:47 PM

Having the same problem on my laptop, which doesn't have visual studio installed on it in the first place. Have gone through all the recommended solutions, and have tried repeatedly downloading 10.1 with no joy :(

avatar image ModernRyoga ♦♦ STAFF Dec 15 '15 at 10:04 PM

Hi Russ,

Are you getting the same error message? Could you please provide a screenshot of the error?

avatar image Max1511 Feb 01 '16 at 08:33 PM

I can't install UE4. Error code: R-1638. I deleted Mincrosoft Visial C ++ 2015. I reinstalled the launcher. Nothing happens. Why?

avatar image ModernRyoga ♦♦ STAFF Feb 03 '16 at 09:23 PM

Hello!

A new version of the launcher has been released. It addresses some of the prereq issues. If you are still having trouble, please try downloading and installing the latest version. If you are still having trouble. Please create a new AnswerHub topic so that we may better track your issue.

The release notes for the launcher update can be found here:

avatar image game666 Mar 15 '16 at 06:32 PM

Nothing of the above works here. I am trying for the fourth time to install UE 4.10.4. Until now I had only, uhm, epic fails.

Got code 1223, but had not even VC 2015 on my machine. Updating Win does not help either. Uninstalled VC 2013 just recently and will try for a last time. Would be fine to get UE running though since I need it for my game design classes. Can't really believe that it is so hard to install UE4. UDK was (almost) no problem at all, had even several versions on the same machine and everything worked (again almost) like a charm.

Specs: i7, 8 Gb RAM, 4Gb Video-RAM, Win 7 64bit Home Premium and a lot of desperation

avatar image game666 Mar 15 '16 at 08:22 PM

EpicGamesLauncherInstaller-2.11.0-2904489.msi (download from today) does one more funny thing to my machine: now I can't even choose an engine to install. The only thing it lets me choose is an engine preview, and then nothing happens.

ue4inst.msi (a download from yesterday) allows to install 4.9.2 which does work (sigh). Never change a running system, so I won't update for the next five years or so. No, really, 4.10.x seems to have broken something, doesn't it?

At least I am happy to get my hands on UE4 now :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Apr 21 '16 at 08:48 PM by Stephen Ellis for the following reason:

The question is answered, right answer was accepted. For new issues please visit http://help.epicgames.com/ for Launcher support


11 answers: sort voted first

Alright so I have the same problem and do not have the time to test this fix right now, but as my error alternates between 1223 and 1638 - and the issues seem the same, maybe this helps: https://answers.unrealengine.com/questions/331994/410-installation-failed-with-error-r-1638.html

more ▼

answered Dec 03 '15 at 11:19 PM

avatar image

RamnGames
41 1 2 5

avatar image tardygrade Dec 03 '15 at 11:30 PM

Bingo ! That was it. Just uninstalled VC2015 redistributables (I did both 64 and 86) from the control panel and rerun 4.10 installer. It worked !

avatar image JBN2171 Dec 04 '15 at 02:00 AM

Tardygrade!!!! Thank You!!!! Your procedures solved my installation problem, and now the Unreal Engine 4.10 works fine!!!! So, for our cases the problems was solved!!! Greetings!!

avatar image thepsrag Apr 19 '16 at 03:04 AM

After i did that i am now getting code 0

avatar image samcoolholt Dec 29 '15 at 12:16 PM

Worked perfectly guys! :) thanks a bunch.

avatar image JedTheKrampus Jan 17 '16 at 09:47 AM

You may also have to remove the UE4 prerequisites using the control panel as well.

avatar image Stephen Ellis ♦♦ STAFF Apr 21 '16 at 08:47 PM

For anyone still experiencing this issue, try the various solutions listed in this post, but if the problem still persists please visit http://help.epicgames.com/ for technical Launcher support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, just wanted to say that I ran in to this issue today. After trying all the suggested solutions with no luck, I tried doing a right-click Run as Administrator on the shortcut while executing the Launcher, and the setup to 4.10.2 completed fine. It was just a permissions issue but was throwing the prereq error.

more ▼

answered Jan 12 '16 at 01:02 AM

avatar image

Confuishus
6 1

avatar image Radek89 Jan 13 '16 at 03:06 PM

Run as Administrator, it worked to me! Thanks!

avatar image MadCylinder123 Jan 19 '16 at 05:25 AM

This worked for me too

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I ultimately had to remove and reinstall 4.10 all-together to get this working. This is after trying everything above:

  • Running Windows Update

  • Installing Visual Studio 2015

  • Uninstalling Visual Studio 2013

  • Removing 2015 C++ Redistributable packages (x86 and x64)

  • Running Epic Game Launcher as administrator

  • Repairing Visual Studio 2015

  • Reinstalling Epic Game Launcher

This minor release was definitely a (T)otally (U)n(R)ecoverable (D)istribution to get installed. After all the above failed, I removed 4.10.1 then added the 4.10 version again and 4.10.2 installed like a champ. :P

One and a half days later, back to what I was working on... ~ Fly first, crash later...

more ▼

answered Jan 17 '16 at 12:58 PM

avatar image

KeyserSoze4040
6 1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Disable antivirus during install, it appears that epic .exe give false positive in some antivirus, also in cooked applications!

more ▼

answered Feb 08 '16 at 01:39 PM

avatar image

CarloAlt
1 1

avatar image Deus_Ex_Machina_ Feb 13 '16 at 08:08 AM

Thank you mate. Finally installed the UE4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Tried all of the above listed solutions but continued to get the Prerequisite error. I had the 2015 C++ redistributables installed, although I did not have VS 2015 or any previous version on my Windows 8.1 Install.

  • I deleted them and then tried to install UE4 from the Epics Game Launcher and got the same error

  • I installed the 2015 C++ redistributables from microsoft site and still got the same error

  • I installed the Visual Studio Community Free edition, then relaucned Epic Games Launcher and UE4 installed without any errors.

more ▼

answered Dec 10 '15 at 10:26 PM

avatar image

nymets1104
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This definitely worked for me also thank you tardygrade and JBN2171 for logging it on here - I did the same thing "... uninstalled VC2015 redistributables (I did both 64 and 86) from the control panel and rerun 4.10 installer. "

I also had to disable my Bitdefender Total Internet Security through the installation process while installing UNREAL ENGINE 4 v10

Cheers for updating it on here, I was pulling my hair out trying to fix it!

more ▼

answered Dec 12 '15 at 03:14 PM

avatar image

Suchet
1 1 1

avatar image ShadesOfRain Dec 22 '15 at 05:29 PM

For me, simply deleting the redistributables (VS 2015 x86 and x64) was not enough. I had to also download the lastest versions of them from the Microsoft site and then install them. It was only after the previous redistributables were deleted and new copies were installed that it worked.

I also added exception folders to my anti-virus for the Unreal Engine folder just to be safe. Anti-virus software has interfered with me being able to install and use Visual Studio 2015. It seems other people are having similar problems with anti-viruses messing up VS 2015 installs, not just within UE4 but in other contexts also.

Also, maybe the redistributables that came bundled with UE4 or VS2015 were bad or had install errors?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the same problem on an i7 @3.4GHz, with Windows 10 64bits with 16GB RAM and 1GB video card. Without doing any of the above solutions (I didn't deinstall or reinstall anything, I was still reading your kinf answers), on its 5th attempt UE 4.10.1 installed itself succesfully.

more ▼

answered Dec 13 '15 at 06:55 PM

avatar image

Anjesen
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello I had the same issue but solved it like this: right click on app>properties> security tab>Edit>choose user name on the list>give full control

more ▼

answered Jan 16 '16 at 02:25 PM

avatar image

Minyth
1

avatar image MadCylinder123 Jan 19 '16 at 05:25 AM

This worked for me too

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

had the 1223 and windows update made the diff

more ▼

answered Feb 26 '16 at 05:07 PM

avatar image

HansAlan
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've followed only theese steps and it worked, thanks!

nstalling Visual Studio 2015

Uninstalling Visual Studio 2013

Removing 2015 C++ Redistributable packages (x86 and x64)

Running Epic Game Launcher as administrator

more ▼

answered Mar 15 '16 at 05:36 PM

avatar image

BayZi
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

EpicGamesLauncherInstaller-2.11.0-2904489.msi (download from today) does one more funny thing to my machine: now I can't even choose an engine to install. The only thing it lets me choose is an engine preview, and then nothing happens.

ue4inst.msi (a download from yesterday) allows to install 4.9.2 which does work (sigh). Never change a running system, so I won't update for the next five years or so. No, really, 4.10.x seems to have broken something, doesn't it?

At least I am happy to get my hands on UE4 now :)

more ▼

answered Mar 15 '16 at 08:21 PM

avatar image

game666
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question