x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

No particle shadow in 4.10

alt text

alt text

There used to be translucent shadow in 4.8 and versions below 4.8, but i find out that particles cant cast shadow in 4.10, anyone discovered the same situation like me?

Product Version: UE 4.10
Tags:
more ▼

asked Dec 05 '15 at 05:45 PM in Rendering

avatar image

dejack
6 1 3 4

avatar image Logan Bailey ♦♦ STAFF Dec 07 '15 at 09:44 PM

Hello dejack,

Currently translucent materials on particles do not support shadows. Changing the particle material to masked fixes this issue. There is currently a ticket open for this to be resolved. I do not have an ETA for when this will be resolved. alt text

Thank you for reporting this issue to us. This issue is known and will resolved at a later date.

Logan

maskedshadows.jpg (90.6 kB)
avatar image SouldomainTM Dec 08 '15 at 12:44 AM

Are you sure? Or is it another approach that I'm using myself?

alt text

avatar image SouldomainTM Dec 08 '15 at 12:37 AM

It works fine with my 4.10 project.

Have you turned on "cast translucent shadow" for the light source itself? The second screenshot seem to show the details panel of the particle system.

Doc Particle Shadow Casting

avatar image Logan Bailey ♦♦ STAFF Dec 08 '15 at 03:45 PM

Hello SouldomainTM,

In my test I enabled all translucent shadows on the lighting. I also enabled this for the emitter. In theory I should see the shadows.

However, there is a known issue our team is working on that deals with shadows and translucent materials.

Logan

avatar image SouldomainTM Dec 08 '15 at 05:19 PM

I see. I found that the node Depth Fade does remove particle shadows. So it's not possible to have smooth particles and the particles shadows at the same time.

It this one of those issues you talk about?

avatar image Logan Bailey ♦♦ STAFF Dec 08 '15 at 05:48 PM

Correct. We are currently working to improve the quality of those shadows to allow for more control of the shadow being cast.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello -

Translucent Particle Systems if set to Cast Shadows, which by default they are not set to do for performance reasons, will cast shadows in the level.

From 4.9.2: 492

With this question we were able to track down a new issue in 4.10 in which using a Depth Fade node in the Material of your Particle system will break the ability for that system to cast shadows. Assuming you are not using a Depth Fade node in your Material, the Particle System will Cast Shadows as pictured above.

From 4.10.1: DEV_MAIN

I have reported the issue as https://issues.unrealengine.com/issue/UE-24249 and will keep you appraised of new information as we investigate a solution.

Thank You -

Eric Ketchum

depth_devmain.jpg (129.6 kB)
depth492.jpg (96.8 kB)
more ▼

answered Dec 08 '15 at 10:29 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 734

avatar image dejack Dec 10 '15 at 06:11 AM

:) Thanks a lot, u do solve my problem~~

avatar image ash22 Feb 10 '16 at 11:31 AM

I also just hit the issue regarding soft (Depth Fade) particles and shadows.

If you add a [Depth Fade] node to the material of any particle that is casting a shadow then the shadow will no longer render [4.10].

avatar image bparillo Apr 29 '16 at 03:32 AM

This is still an issue in 4.11.2

avatar image Lovecraft_K ♦♦ STAFF Feb 10 '16 at 05:16 PM

Hello ash22 -

We are still actively investigating this issue.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey, seems that depthfade still stops translucent particles casting shadows. Any updates?

more ▼

answered Mar 10 '17 at 10:15 PM

avatar image

Bloodprime
16 1 2

avatar image endlessplumber Jun 07 '17 at 04:29 PM

Just ran into the depth-fade/no translucent shadows issue myself. I'll probably start a new question since they don't seem to be responding here any more.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question