x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GenerateProjectFiles.bat VS2015 error

Hello! First time builder of Unreal here. I have VS2015 installed, and just cloned 4.10 to my D Drive.

Ran Setup, no issues. Running GenerateProjectFiles.bat and:

 GenerateProjectFiles ERROR: We couldn't find a valid installation of Visual Studio.  This program requires Visual Studio 2015 or Visual Studio 2013 or Visual Studio 2012.  Please check that you have Visual Studio installed, then verify that the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\14.0\InstallDir (or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\14.0\InstallDir on 32-bit machines) registry value is set.  Visual Studio configures this value when it is installed, and this program expects it to be set to the '\Common7\IDE\' sub-folder under a valid Visual Studio installation directory.

Checked my registry and the above entries exist. Looked at the bat, found that the "" variable is never set. Looked at "GetVSComnToolsPath.bat", and the TmpPath variable is never set when I run it.

However, if I run the reg.exe command from the file manually:

 D:\git\epic\UnrealEngine\Engine\Build\BatchFiles>REG.exe query HKLM\Software\Wow6432Node\Microsoft\VisualStudio\14.0 /v "InstallDir"
 
 HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\VisualStudio\14.0
     InstallDir    REG_SZ    C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\


Any help or insight?

edit: I am on Windows 10.

Product Version: UE 4.10
Tags:
more ▼

asked Dec 06 '15 at 11:01 PM in Installation & Setup

avatar image

jankcat
1 1 2 4

avatar image Matthew J Dec 07 '15 at 04:38 PM

Hello jankcat,

Just to have a bit more information, what Operating System are you using? Also, can you try verifying your install of Visual Studio 2015?

avatar image jankcat Dec 09 '15 at 06:52 AM

Hello! I am on windows 10. I am not sure what you mean by verifying my install, but you can see in the above snippets that the registry is populated. I ran a "repair install" from add/remove programs, and the error persists.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

That was what I was referring to as verifying, I apologize for the confusion. The next thing to try would be similar. Inside of add/remove programs, start the repair process again for Visual Studio but you should have an option for "Modify" instead of "Repair". This will show you a list of features that can be installed with Visual Studio. Please ensure that you have "Visual C++" under Programming Languages, as well as "Common Tools" selected and then hit Update if necessary. I'm currently looking into what else could be the issue as I'm not 100% sure this will fix it, but it's worth a try and something that may cause problems later if these features are not installed.

more ▼

answered Dec 09 '15 at 03:30 PM

avatar image jankcat Dec 11 '15 at 06:41 PM

Well, after running the Modify, I noticed that C++ was not installed... likely because my experience is as a C# developer...

Facepalm

Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question