x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Refraction On a Translucent Sprite (Paper2d)

Hello!

I would like some help figuring out why i cannot make a heat distortion particle work on a translucent sprite. It works just fine with a masked sprite though.

Problem is that even if i create a .tng file with a separate alpha channel it still looks super bad because i cannot make my backgrounds blend seamlessly together. It looks like i took a ruler and drawn a separation line between the two backgrounds. And i am running out of ideas on how to fake it on a 2d plane.

Could someone please help me with this because i cant find a single line of information about sprites and refraction

Note: I am a noob with materials so please be gentle. :)

Thank you!

Product Version: UE 4.9
Tags:
more ▼

asked Dec 07 '15 at 09:48 PM in Rendering

avatar image

Roccinio
571 51 56 77

avatar image Roccinio Dec 09 '15 at 12:53 PM

Could someone please explain to me why translucent materials do not work with refraction and what can i do as a workaround to make them work?

This is the material.alt text

1.png (345.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Roccinio -

I am going to assume that you are using an Orthogonal Camera. It's your Particle System's relationship to the Orthogonal Camera which is causing the Refraction to not redner. You material is setup correctly. We are currently working on an issue where particles are not rendering correctly in Orthogonal camera views, for reference UE-3602. I have added your information to the report and will keep you informed as we investigate a solution.

Thank You

Eric Ketchum

more ▼

answered Dec 09 '15 at 07:52 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Roccinio Dec 09 '15 at 08:06 PM

Hello Eric,

No I am using perspective. I know for a long time that particles do not render with an orthogonal camera. Any ideas now that this got out of the way?

avatar image Lovecraft_K ♦♦ STAFF Dec 09 '15 at 08:19 PM

Hm, your material setup works correctly for me in Perspective. I have attached a test project can you take a look at it and see if you are getting the same results.

Test Project 4.10.1 Test Project 4.9.2

avatar image Roccinio Dec 09 '15 at 08:39 PM

:cry:

I just tried it out in the default paper2d template and it works. Would you mind taking a look at the video I send you? :cry: link text

untitled.rar (5.1 MB)
avatar image Lovecraft_K ♦♦ STAFF Dec 10 '15 at 05:47 PM

Hi -

Uncheck Separate Translucency in your Translucency Sprite Material. You may have to copy the default Material and make a new one you can edit separately and also you may have to turn off separate Translucency for multiple stacked Translucent items to get the Sort Order correct. This should get you back up and running.

Thank You

Eric Ketchum

avatar image Roccinio Dec 10 '15 at 11:55 PM

Eric.. I owe you a beer!

A big THANK you from the bottom of my heart! Without you I wouldn't be able to figure this out not even in a million years.

For future reference this is what i believe caused my problem. Translucency and DoF don't work well together.

"I did some reading up on the Documentation page and found this little snippet of information that deals directly with the issue you are experiencing. The option 'Separate Translucency' within your material properties under the 'Translucency' section should resolve your issue.

Separate Translucency - This indicates that the Material should be rendered in the Separate Translucency Pass( This mean that this will not be affected by DOF and also requires bAllowSeparateTranslucency to be set in the .INI files).

By default this option is checked on when creating a Translucent Material. Simply uncheck the box for this option and you should be able to see the effects of DoF applied to the objects in your scene.

Andrew Hurley "

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question