x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dynamic Shadows on very large landscape

Hi. I have a very large landscape, around 600x600km2, and shadows wont get any better than this, what can I do??

I am using dynamic light

Product Version: UE 4.9
Tags:
more ▼

asked Dec 08 '15 at 08:07 AM in Rendering

avatar image

ImperiumPandemonium
152 12 12 17

avatar image ImperiumPandemonium Dec 08 '15 at 08:09 AM

Here are pics of my issue, and my settings

alt text

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Do you really need that big distance? I believe it's clamped somewhere deep in the engine, there were issues with it on these boards if I'm correct. Go with:

r.Shadow.MaxResolution X

This will increase the max shadow resolution, but don't go above X == 4096. If that effect does not satisfy you, take into consideration your camera. Is it FPS? Isometric? How big part of the landscape do you actually see at one time? Reducing the range makes the shadow better, because it will have to fit less shadows on the same texture.

There are also several other variables in the r.Shadow section that might help you, depending on the camera / project you're trying to do.

Also, this isn't your regular game options slider. Going with MAX VALUE on all settings doesn't mean you will get the best look. You have to dig deeper, much deeper to get it right.

more ▼

answered Dec 08 '15 at 08:38 AM

avatar image

vipeout
374 13 10 25

avatar image ImperiumPandemonium Dec 08 '15 at 02:02 PM

It is fps/thirdperson, and yes I need that distance because sometimes you see across over 50 km infront of you, and then the visible mountains and valleys don't render any shadows at all.

But I will go inte visual studio and try your solution. And I have tried several different value settings before deciding with maxing all the values, that seemed to give me the best result.

Thanks for the tip about r.shadow.maxResolution,

avatar image ImperiumPandemonium Dec 09 '15 at 04:34 AM

Ok I changed the ShadowResolution and scaled down the dynamic distance a bit, together it works perfectly!

Thanks for the tip

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question