Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm "Busy, Unassigned" in small Dev team enviroment

We have Swarm setup and the Coordinator is able to see all the machines, pings are all successful and if a light build is initiated on a machine, it will output too all machines - If they are not being used.

The problem we have is we want Swarm to use a couple of cores from each machine whilst we are using them for other things.

For example: 2 machines running Photoshop will appear as busy in the coordinator yet in the task manager, the CPU is at 10% max and ram usage is at about 15%....

1) Is there anyway of getting Swarm to use the rest of the machine, or half of the available computing power?

2) What are the requirements for the Swarm Agent to declare a machine "Too Busy" for any Swarm rendering

Product Version: UE 4.10
more ▼

asked Dec 09 '15 at 09:28 AM in Using UE4

avatar image

31 2 4 6

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

There are several questions to this problem here.I post my solution here in a random post

In my case I realized that svchost.exe was running at 25% CPU power which caused the busy status. I went to find out more about this process here and installed the ProcessExplorer to analyze it. In my case it turned out that the Windows update service was consuming all the power. I didn't allow updates to be installed automatically but it had some updates waiting. Once I turned "check for updates" off and restarted, the 25% load disappeared and the agent reports as "Available" now. Hopefully this will help someone with the same problem

more ▼

answered Dec 02 '16 at 07:37 PM

avatar image

612 33 42 75

(comments are locked)
10|2000 characters needed characters left

1) from my experience, if its unassigned, and the agent is running, it will get a job assigned, no matter if its busy, but not 100% sure. But it wont get disrupted if it's runnig gonce, so maybe if you are baking, just tell the people to stop doing stuff for a second? :D

2) Yes, In your SwarmAgent under the settings tab, there is a "Developer Settings" area, toggle to true to unhide the DeveloperSettings-Tab, there you can set the LocalJobsDefaultprocessorCount and RemoteJobsDefaultProcessorCount to the number of cores you want it to use.

more ▼

answered Dec 09 '15 at 11:44 AM

avatar image

379 14 19 37

(comments are locked)
10|2000 characters needed characters left

Hi all. I just cleared the SWARMCACHE Folder and it ran again

more ▼

answered Nov 20 '18 at 11:04 AM

avatar image

1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question