x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Error R-1603

I've been trying to get this installer working for days, to no avail. I run it as an admin, I even installed Visual Studio.

I've installed every update I could for Windows 7, except for the Telemetry/Windows 10 ones (which I hid). If even those are required to be able to use this program, that would be ridiculous.

Logs folder .zip'd logs

dxdiag .txt log

Product Version: Epic Games Launcher
Tags:
logs.zip (234.1 kB)
dxdiag.txt (51.4 kB)
more ▼

asked Dec 09 '15 at 04:06 PM in Installation & Setup

avatar image

Shade Vortex
11 1 3 5

avatar image Leebowitz ♦♦ STAFF Dec 09 '15 at 05:54 PM

Hello Shade Vortex,

I'm sorry to hear that you are having trouble. Other user have had similar issues and have followed the steps on this post to resolve the issue.

Please try the solutions provided there. If you are still unable to install the launcher, reply back and we will continue to look into the issue for you.

avatar image Shade Vortex Dec 15 '15 at 05:21 PM

I tried uninstalling every version of Microsoft Visual C++ that I had installed (from 2008 to 2015), and attempting to install the program again based on what the posts in that link you gave me, Leebowits . No luck.

avatar image Leebowitz ♦♦ STAFF Dec 15 '15 at 07:55 PM

Hi Shade!

I'm sorry to hear that didn't work for you. Just to clarify what you did:

-You uninstalled the Epic Game launcher. -You uninstalled Microsoft Visual C++ 2015 (X64) and (X86). -Rebooted. -Downloaded and installed the latest version of the Epic Games launcher.

Do you receive the error message when you start the launcher or when you attempt to download the UE4 editor? This issue has been seen specifically with version 4.10. Could you please provide a screenshot of the error message?

Thanks!

avatar image Shade Vortex Dec 15 '15 at 10:49 PM

I was trying to download the launcher to get Shadow Complex on PC while it was still free. After the first percentage bar goes to 1000%, it moves onto installing prerequisites, it loads for a while, then it has this error: https://i.imgur.com/ybDVxAb.png

avatar image Leebowitz ♦♦ STAFF Dec 16 '15 at 07:45 PM

Hello again Shade Vortex,

Do you have any of the other epic products installed on your system at the moment or just the launcher?

avatar image Shade Vortex Dec 16 '15 at 11:37 PM

Here's all the Epic-related software I have installed: Epic Games Launcher, UDK 3913-07, Antichamber, SonicGDK Public Release 7 (it's a Sonic the Hedgehog fangame engine), and UDK 2015-01.

avatar image Leebowitz ♦♦ STAFF Dec 17 '15 at 07:05 PM

Hi Shade Vortex,

After doing a bit more digging into your logs it appears, there may be a .NET Framework issue. Please visit the MS support page here and attempts the fixes provided. After which,please try your install again.

Just to verify, the error message is coming up when you start the launcher and it attempts to update or AFTER you have logged into the launcher and are trying to install Shadow Complex?

avatar image Shade Vortex Dec 17 '15 at 08:15 PM

I downloaded the epic games launcher from the Shadow Complex PC page, I installed it, I launched it, it updates, and then it tries to install prerequisites and fails with that error after a while. I never actually see the Epic Games Launcher get past that and actually launch.

I tried the .net repair tool and the MSI tool that fixes the update registration corruption, but that still didn't fix the launcher.I'll try reinstalling the .net versions later when I reboot my PC, since they won't fully uninstall unless I do so.

avatar image Leebowitz ♦♦ STAFF Dec 18 '15 at 07:45 PM

Alright. Thanks for the update.

avatar image Shade Vortex Dec 18 '15 at 11:19 PM

Well, I uninstalled every version of MS .net I had installed and have been reinstalling them. I have 1.1, 4.6.1 and 3.5. Any others that I need to get?

avatar image Shade Vortex Dec 19 '15 at 10:42 PM

I tried installing again with those versions of .net installed, and it still failed. I then tried installing the 2013 C++ Visual Studio runtime, x86 and 64, then tried again. It still failed. Here's the updated logs: Logs from today

logs2.zip (42.8 kB)
avatar image Leebowitz ♦♦ STAFF Dec 21 '15 at 08:21 PM

Hello again Shade!

Alright, let's see if we can run the launcher prerequisites manually. Reboot your machine to make sure that the launcher is not running.

-Click the "Start" button in the bottom right and type in "%temp%" in the search field.

-Open the temp folder that appears and clear out all content dated prior to today. Some files may not delete, you can sip those.

-Navigate to:

C:\Program Files (x86)\Epic Games\Launcher\Portal\SelfUpdateStaging\Install\Portal\Extras\Redist

-Run the file "LauncherPrereqSetup_x64.exe" as admin.

Once you've done this, please try starting the launcher again and let us know.

avatar image Leebowitz ♦♦ STAFF Jan 04 '16 at 08:14 PM

Hi Shade,

Any update?

avatar image Shade Vortex Jan 04 '16 at 08:43 PM

It gave me a fatal error during installation. Here's the log: link text

avatar image Leebowitz ♦♦ STAFF Jan 12 '16 at 07:31 PM

Hi Shade,

I see that there is an accepted answer for your ticket. Is your issue resolved? If not, please let me know and I will get a bug report in for you.

avatar image Shade Vortex Jan 12 '16 at 07:48 PM

Still not fixed for me. I've tried everything suggested so far, no luck.

avatar image Leebowitz ♦♦ STAFF Jan 20 '16 at 03:34 PM

Your issue has been logged as JIRA OPP-5049. As soon as I have more information I will reply back to you. In the meantime, could you please try downloading and installing the launcher from the latest msi available from your Epic account page?

avatar image Shade Vortex Jan 20 '16 at 07:47 PM

Seems to have the same result. Here's the logs: [Logs][1] [1]: /storage/temp/75290-newlogs.rar

newlogs.rar (30.8 kB)
avatar image Haskellf Jan 22 '16 at 04:46 PM

Has this been resolved? If so, can you share your workaround?

avatar image Shade Vortex Jan 22 '16 at 04:53 PM

Same result, as I said. As in same error, not resolved.

avatar image Kenjamin Jan 24 '16 at 03:04 AM

I'm getting pretty much the same error. I don't know why so many people are having this problem and Epic has no idea how to fix it.

avatar image 0xDEADBEEF STAFF Jan 26 '16 at 03:46 PM

Hi Shade Vortex, I've been assigned to look into your issue and I wanted to thank you for the time you spent collecting and providing all the logs. They are very helpful. The error code is rather generic and can cover a number of issues so the logs really help here. Chances are that other users in this tread are running into something different but I can't confirm without logs. In short, your issue is caused by our prerequisites installer failing to install DirectX on your system. It is timing out for some reason. This is odd because we just package up Microsoft's DirectX installer so we are at its mercy. With the current launcher setup I don't have a workaround for you but I will add something that will let you bypass the problem. This will be available with the next launcher release. I'll continue to investigate the DX issue to see if we can't pinpoint the problem further.

If you would like to try something in the mean-time, you can grab the DirectX End-User Runtimes installer from here: LINK Install that and see if it is successful. If so, try the launcher installer again. The DirectX install workflow is a bit unique so this is a longshot but probably worth a try.

avatar image 0xFAN Dec 09 '15 at 06:02 PM

Exactly my situation here, it's been at least 1 week, and the problem is still there, the launcher always gives error R-1603:

I also tried running the launcher as Administrator, running the prerequisite installer manually(as administrator), uninstalling Visual C++ redist 2015 {x86,x64}, reinstalling Visual Sudio 2015 Update 1 a few times, running "sfc /scannow", fixing directory/registry permission errors a few times, and I'm still getting this error.

I'm running Windows 10 (build 10568) and Visual Studio 2015 Update 1.

link text

link text

logs.zip (78.8 kB)
dxdiag.zip (12.9 kB)
avatar image 0xDEADBEEF STAFF Jan 26 '16 at 04:28 PM

Hi 0xFAN, Sorry you are running into the issue. Thanks for providing the logs though, super helpful in pinpointing the problem. There are similarities between your issue and the issue the original poster is having but the underlying cause seems to differ which is why we typically prefer a separate thread to be started. Your issue is similar because you are seeing the R-1603 error code. This tells us that the prerequisites installer failed. Further investigation of your logs shows that DirectX failed to install. This is also similar with the original poster. The difference is that your DirectX install failed with code: -9. We'll look into better relaying this info to the user in future releases.

We have seen DirectX return code -9 in the past but finding meaningful info on why it would return -9 has proved rather difficult. The short answer is that I don't know. Yet.

As I posted above, we don't have a workaround with the current launcher setup. I will add something that will let you bypass the problem. It will be available next launcher release.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Feb 15 '17 at 10:22 PM by Stephen Ellis for the following reason:

The question is answered, right answer was accepted


3 answers: sort voted first

With the release of the latest Epic Games Launcher, comes a new workaround for this issue. NOTE: This workaround only applies to issues with the launcher prerequisites installer(LauncherPrereqSetup_x86.exe or LauncherPrereqSetup_x64.exe). If you are having problems installing prerequisites for engines or other products, this is not the thread for you.

  1. Manually download and install DirectX from here: Link

  2. Install Microsoft Visual C++ 2010 Redistributable Package (x86). On 64bit Windows also install Microsoft Visual C++ 2010 Redistributable Package (x64)

  3. Install Visual C++ Redistributable for Visual Studio 2012. On 32bit Windows install vcredist_x86.exe. On 64bit Windows install both vcredist_x86.exe and vcredist_x64.exe.

  4. Install Visual C++ Redistributable Packages for Visual Studio 2013. On 32bit Windows install vcredist_x86.exe. On 64bit Windows install both vcredist_x86.exe and vcredist_x64.exe.

  5. Install the latest Launcher and if you encounter Error R-1603 hit OK

  6. Right click on your Epic Games Launcher desktop shortcut and select Properties. Under the Shortcuts tab, find the Target field and add this to the end of it(pictured below): -SkipBuildPatchPrereq

  7. Double click the desktop shortcut.

  8. As soon as you are able to get into the launcher after self update completes, close it and remove the -SkipBuildPatchPrereq flag from your shortcut. Startup the launcher again.

alt text

more ▼

answered Feb 04 '16 at 07:30 PM

avatar image

0xDEADBEEF STAFF
1.5k 18 11 47

avatar image Shade Vortex Feb 04 '16 at 08:44 PM

Thanks, this -finally- worked. I did all the steps but the one that fixed the problem was skipping the building of the prerequisites. It's too bad it took this long for this issue to be resolved, the free month of Shadow Complex is long over- it was the main reason I wanted to install Epic Games Launcher. Oh well, I'm sure I'll make use of it later...

avatar image Leebowitz ♦♦ STAFF Feb 05 '16 at 06:06 PM

Shade,

Glad to hear that your issue has been resolved. You should now be able to download Shadow Complex. Enjoy!

avatar image DanilShekarev Apr 05 '16 at 03:26 AM

Thank you very much helped!

avatar image Shade Vortex Feb 05 '16 at 06:35 PM

Thanks a lot!

avatar image CPalmroos Jun 14 '16 at 03:33 PM

OMG! Was struggling with this and this finally worked. Thank you very much :)

avatar image 马三小伙儿 Dec 04 '16 at 08:09 AM

Thanks a lot! It works well!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

As others have already noted, this is a rather common problem that people seem to be encountering. I've experienced it myself, as well. There's a couple things to check and do if you're running into this issue, as outlined below:

  • Be sure that the version of Windows you are using is fully updated.

  • Head to C:\Program Files (x86)\Epic Games and be sure that the engine hasn't already been installed previously. Delete any existing installs that might be causing a conflict.

  • Try and uninstall "UE4 Prerequisites" from the control panel.

  • Attempt to uninstall and re-install the launcher and download the engine.

  • Try and install "UE4 Prerequisites" manually, by accessing the exe here: C:\Program Files\Epic Games\4.10\Engine\Extras\Redist\en-us

  • Remove VS 2015 C++ redistributable x64 and x86. You can reinstall them after you've fixed the engine issue.

It is likely that following these will solve this problem, as illustrated by others already. If you still have trouble, reach out to Epic

more ▼

answered Jan 08 '16 at 07:03 AM

avatar image

DanielBennifer
150 12 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I fixed it for my system. I don't know how this happened, on a fresh install of Windows 10 no less, but somehow my permissions were completely screwed.

Here is the steps I used to have everything install correctly without anymore 1603 errors or DirectX fails:

Open My Computer and right click on the system drive (C: in my case, even though I was installing it to D:), click on Properties.

Click on the Security tab, and then click on Advanced. Ensure the SYSTEM user is there and that it has Full Permissions (mine did, so I didn't think anything was wrong).

Even if it already has Full Permissions, click on "Change Permissions" on the bottom with the UAV shield icon on it.

On the bottom of this screen, after ensuring SYSTEM has full permissions, check the box at the bottom that says "Replace all child object permission entries with inheritable permission entries from this object."

Click Apply and it might ask you to once again grant it permission and then it will go through all files and folders on your system drive and re-apply those permissions.

It will throw errors about the pagefile and other things saying it can't modify those, which is fine. Those are all files that are currently in use by the system and don't want to touch those anyway.

After it completes, or during it may say the Recycle Bin has become corrupted and you will need to empty it. Go ahead and click OK and everything should be good to go.

Like I said, there isn't any reason a fresh install of Windows shouldn't have the System account have full access to everything. It's really weird. Hopefully the admins here can add this to their toolkit to help with people experiencing these weird errors.

more ▼

answered Jan 24 '16 at 06:28 AM

avatar image

Kenjamin
1 1 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question