x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shadow flickering on Skel Meshes on iPad in 4.9

My team is trying to figure out why there is severe shadow flickering on our skeletal meshes. The flickering appears on iPad Air 2, but the mobile preview on PC looks fine. All the other modulated cast shadows received by static meshes work correctly on iPad, though.

Here is our scene setup:

Full HDR w/Sun

1 stationary directional light with "Cast Modulated Shadows" option checked on

When viewed on iPad Air 2, skeletal meshes (both playable characters, as well as metal bins with baked destruction animation) receive shadows cast from the surrounding static meshes (walls, roofs, etc), these shadows flicker like crazy on the skeletal meshes. They have ‘Dynamic Shadows’ and ‘Static Shadow’ options checked on by default.

I have included a screen capture of the metal bin skeletal meshes. The large black shapes are the flickering shadows. I can email you a video of the metal bins, too, if you would like.

Also, we haven’t announced this project yet, so I can’t show the characters, but they exhibit the same shadow flickering as the metal bin skeletal meshes on iPad Air 2.

Thanks again for any help you might have!

NoaScape

Product Version: UE 4.9
Tags:
more ▼

asked Dec 10 '15 at 06:26 AM in Rendering

avatar image

NoaScape
0 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello NoaScape,

There are a few possibilities that come to mind regarding the shadow flickering. I have a few questions to clarify a few suspicions I have.

  1. Are you using a FOV that is non default. Within 4.9 there was a bug reported that turned the screen black if a FOV different than 90 and " Cast Modulated Shadows " was used. This bug was fixed as of 4.10.

  2. Does Switching to LDR resolve this issue?

  3. Please be sure that all of your textures and light maps are a power of 2.

  4. Have you tried launching or packaging using 4.10? If not would you test an asset that is giving you this issue within a test project using the same lighting and shadows that you are in your 4.9 project.

After completing these troubleshoots please post again with the results of each one.

Logan

more ▼

answered Dec 14 '15 at 05:48 PM

avatar image NoaScape Dec 15 '15 at 01:19 AM

Thank you for your reply! We are using a custom FOV, so we will try your suggestion. Also, we will be moving over to 4.10 in the next week or two, so we will confirm if that resolves the issue.

Thank you very much!

avatar image NoaScape Dec 18 '15 at 04:12 AM

We just tested it on 4.10, and are still getting the shadow flickering. We will try LDR next, although we might just turn off Modulated Shadows in the end. I will post again soon!

avatar image Logan Bailey ♦♦ STAFF Dec 22 '15 at 03:54 PM

Hello NoaScape,

I haven't heard from you in a few days. I was wondering if you had a chance to test this further?

Logan

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question