Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Localization causes crash only when packaged with UAT

So I've been debugging this issue for a few days and it's got me 100% stumped.

I'm using the unreal dashboard to build localization files, and it's generating locres files and everything exactly as expected. It works locally, and even when I package locally it works perfectly, but when we build it with our automated build system, all the builds crash immediately on startup with the following error:

 Fatal error:         [File:OURGAMEDIR\UnrealEngine\Engine\Source\Runtime\Core\Private\HAL\FileManagerGeneric.cpp] [Line: 605] 
 Invalid BufferCount=0 while reading OURGAMEDIR/LatestCookedBuild/WindowsNoEditor/OURGAME/Content/Localization/Game/en/Game.locres. Pos=43412, Size=19876, PrecacheSize=2147483647, PrecacheOffset=43412

It looks like the game thinks the locres file is almost 2 times larger than it actually is, or maybe that it thinks the start of the file should be offset into another file like a pak file or something.

We're building using this command in the script running on our build machine:

 call ..\UnrealEngine\Engine\Build\BatchFiles\RunUAT.bat BuildCookRun -project="%CD%\OURGAME.uproject" -noP4 -platform=Win64 -clientconfig=Development -cook -allmaps -compile -stage -pak -archive -archivedirectory="%CD%\..\out" -Build

I've tried setting it to package a number of ways including just copying the localization directory into content without including it in the pak file and I have no idea where to even start with this. Any help would be great.

Product Version: UE 4.8
more ▼

asked Dec 11 '15 at 01:30 AM in Packaging & Deployment

avatar image

703 40 32 123

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Jul 07 '16 at 03:12 PM by Samantha Sutton for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks!

1 answer: sort voted first

So just updating this. It seems to be an issue to do with something that the localization dashboard adds to config files that causes issues, but specfically the localization dashboard stuff not the stuff you'd add if you were doing it by hand.

Redoing it by hand worked fine and it's functional now. Not sure why it was messed up with the localization dashboard stuff, but I'm content just to see it working.

more ▼

answered Dec 11 '15 at 08:47 PM

avatar image

703 40 32 123

avatar image Jamie Dale STAFF Dec 11 '15 at 10:45 PM

Would you be able to provide the broken and working config files so that we can examine them?

You can email them if you don't want to post them here - first.last@epicgames.com. Replace first and last with my name :)

avatar image mrooney Dec 12 '15 at 06:27 PM

I think I could do that. I'll send them when I'm back at work on Monday :)

avatar image mrooney Dec 14 '15 at 02:55 PM

K Jamie, it should be sent. Thanks much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question