x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.10.1 Crash

Hi, I recently updated my project from 4.7 to 4.10 and now my project crashes...

I have no clue off what might be the problem. It doesn't happen all the time and when it does, it looks like it's happening completely randomly. Apparently there are two problem because I get two different crash report.

Sadly I have a limited knowledge of programming so I don't really know where to start. The project is nearly done and I am a bit freaking out. I have spend the last 8 month working on it and it looks really great (to me at least)...

So if someone could please take a look or tell me where should I start, it would be grately appreciated!

I have included the end of the log. Before that everything looks stable.

Thanks in advance

First crash report :

Unknown exception - code 00000001 (first/second chance not available)

TerminusB01_03!FDebug::AssertFailed() TerminusB01_03!FTickTaskManager::EndFrame() TerminusB01_03!UWorld::Tick() TerminusB01_03!UGameEngine::Tick() TerminusB01_03!FEngineLoop::Tick() TerminusB01_03!GuardedMain() TerminusB01_03!GuardedMainWrapper() TerminusB01_03!WinMain() TerminusB01_03!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

Second crash report :

"Assertion failed: !NewlySpawnedTickFunctions.Num() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Engine\Private\TickTaskManager.

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\misc\outputdevice.cpp:374] UE4Editor_Engine!FTickTaskManager::EndFrame() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\ticktaskmanager.cpp:1246] UE4Editor_Engine!UWorld::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\leveltick.cpp:1275] UE4Editor_UnrealEd!UEditorEngine::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\editorengine.cpp:1347] UE4Editor_UnrealEd!UUnrealEdEngine::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\unrealedengine.cpp:361] UE4Editor!FEngineLoop::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2427] UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:142] UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

link text

Product Version: UE 4.10
Tags:
log01.txt (4.2 kB)
more ▼

asked Dec 11 '15 at 01:40 PM in Bug Reports

avatar image

petitbreton
21 1 3 4

avatar image Doug E ♦♦ STAFF Dec 11 '15 at 03:58 PM

Hey petitbreton-

Could you post the log files for the crashes as well? Additionally, what were you doing when the crash occurred? Did this happen when you tried to play in the editor or did it crash immediately on opening the project? Is there any code in the project? If so can you compile the code and let me know if there are any compile errors? If you still have a copy of the 4.7 version of the project can you try to upgrade through each engine version (4.7 -> 4.8 -> 4.9 -> 4.10)?

Cheers

Doug Wilson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Doug,

thanks a lot for your fast answer. I moved to 4.10 because there was a bug in 4.7 when I would launch the game that seemed to be fixed by upgrading to 4.10. Then I discovered the nasty crash I wrote this post about.

So I followed your input and went back to 4.7 and fixed the previous bug by the simplest thing... Saving with a new name...

So I am back to a fully functional 4.7 version and will end the project with this version before checking if upgrading to 4.10 is doable.

So problem solved (for now). Thanks a lot for your help. It's nice to know we are not alone in that infinite ue4 univers ;-)

more ▼

answered Dec 13 '15 at 04:30 PM

avatar image

petitbreton
21 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question