Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Source Control

Using 4.10.1 to rewrite all my code from a 4.9.2 project (package issues unresolved.) I have successfully set up source control within the editor, checkout, sync and everything else. Problem is, when I shut down the editor and reload it, all the source control information is gone and I need to hook it back up to source control! I don't know how this would effect things if I leave assets checked out, shut down editor, then reload.. Will assets come back as checked out?

I believe this is a bug because everything was fine in 4.9.2. I am using Perforce.

Any help would be appreciated, thanks

Product Version: UE 4.10
more ▼

asked Dec 12 '15 at 11:20 PM in Bug Reports

avatar image

1.4k 70 29 92

avatar image jtsmith Dec 13 '15 at 05:31 AM

Oddly enough, after several editor shutdown's and restarts it's magically working.

avatar image jtsmith Dec 14 '15 at 04:53 AM

Nevermind, it's forgetting my source control again... Any ideas? Thanks

avatar image Doug E ♦♦ STAFF Dec 14 '15 at 06:45 PM

Hey jtsmith-

I'm not sure I understand what you mean by the source control information being gone. Could you elaborate on what you mean? A project does not store the workspace it was connected to so this must be set every time the project is opened. If you are referring to something else can you provide a screenshot of what you mean when you open the project?

avatar image jtsmith Dec 14 '15 at 08:51 PM

Hey Doug, thanks for the reply. Yes, I mean I have to enter the source control information every time I load the project. It's odd you say it doesn't keep track of the source control workspace because up until 4.10.1 it did. I have 1 project on git which is 4.10.0 (I haven't loaded it since I updated to 4.10.1) and another that is perforce on 4.9.2 and both keep its workspace saved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After speaking with other developers it appears it is possible to have a project automatically connect to source control by setting the ini files properly. I am not familiar with this setup however, if this was working for you in 4.9.2, it may help to compare the ini files from the 4.9 project against the 4.10 ini files.


Doug Wilson

more ▼

answered Dec 14 '15 at 09:47 PM

avatar image jtsmith Dec 15 '15 at 02:39 AM

Thanks Doug, I rifled through the tons of .ini files and found the right one and set it. For those of you in the future who may be experiencing the same issue, here is how the file should look like. It is found in the /Saved/Config/Windows/SourceControlSettings.ini folder/file. The structure should be as follows:

 Port=<perforce port information>
 Workspace=<your workspace>
 HostOverride=<can be left blank but should have 'HostOverride='>

This, of course, is for perforce. As for the other source control options, I'm not sure what it would look like. Hope this helps anyone in the future.

Doug, maybe you can put a word into the developers and let them know that something happened in the last update or two which has prevented the editor from automatically setting the information into this file? Seems if it did it before, it should continue to do it? Silly to have to either manually hook it up to your workspace at each load or to have to manually set your .ini file, assuming you know the proper structure to do so.

Thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question