x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

make SlateViewer Error: After Building UnrealHeaderTool...

I run make Slateviewer in the directory of setup.sh. I'm following this guide. I'm installing on ubuntu 15.04 https://techpromad.wordpress.com/2015/03/14/running-unreal-engine-4-on-ubuntu/

This is the error I get:

 diatom@BroodMother:/media/diatom/Data/ProgramFiles/UnrealEngine-release$ make SlateViewer
 bash "/media/diatom/Data/ProgramFiles/UnrealEngine-release"/Engine/Build/BatchFiles/Linux/Build.sh SlateViewer Linux Development  
 Building SlateViewer...
 Using clang version '3.5.0' (string), 3 (major), 5 (minor), 0 (patch)
 Creating makefile for SlateViewer (no existing makefile)
 Performing full C++ include scan (no include cache file)
 Building UnrealHeaderTool...
 ERROR: System.ComponentModel.Win32Exception: ApplicationName='/media/diatom/Data/ProgramFiles/UnrealEngine-release/Engine/Binaries/DotNET/UnrealBuildTool.exe', CommandLine='UnrealHeaderTool Linux Development -NoMutex', CurrentDirectory='', Native error= Cannot find the specified file
   at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0 
   at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0 
   at System.Diagnostics.Process.Start (System.Diagnostics.ProcessStartInfo startInfo) [0x00000] in <filename unknown>:0 
   at UnrealBuildTool.ExternalExecution.RunExternalExecutable (System.String ExePath, System.String Commandline) [0x00000] in <filename unknown>:0 
   at UnrealBuildTool.ExternalExecution.ExecuteHeaderToolIfNecessary (UnrealBuildTool.UEBuildTarget Target, UnrealBuildTool.CPPEnvironment GlobalCompileEnvironment, System.Collections.Generic.List`1 UObjectModules, System.String ModuleInfoFileName, UnrealBuildTool.ECompilationResult& UHTResult) [0x00000] in <filename unknown>:0 
   at UnrealBuildTool.UEBuildTarget.Build (IUEToolChain TargetToolChain, System.Collections.Generic.List`1& OutputItems, System.Collections.Generic.List`1& UObjectModules, System.String& EULAViolationWarning) [0x00000] in <filename unknown>:0 
   at UnrealBuildTool.UnrealBuildTool.RunUBT (System.String[] Arguments) [0x00000] in <filename unknown>:0 
 make: *** [SlateViewer] Error 5

any ideas?

Product Version: UE 4.10
Tags:
more ▼

asked Dec 13 '15 at 01:08 AM in Installation & Setup

avatar image

Diatom
21 1 3

avatar image Diatom Dec 13 '15 at 01:28 AM

I installed this in my Data partition by extracting the zip file and had to add sudo to some sh files to give it permission to run. I'm trying to reinstall using git this time around. I'll report on how it goes.

avatar image Diatom Dec 13 '15 at 02:53 AM

Doing it this way worked flawlessly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Redid the installation with git and it worked.

more ▼

answered Dec 13 '15 at 02:54 AM

avatar image

Diatom
21 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question