x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android blank project package failed

Hi, i tried to package Android apk file for the first time and run into problem: i created empty new mobile c++ based project with Unreal engine 4.9.2 from GitHub downloaded and installed Nvidia CodeWorksforAndroid 1R3(selected 1R1 in menu before installation) with android-ndk-r10e, apache-ant-1.8.2, jdk1.7.0_71 android-sdk API 23 Connected my device Nexus 4, it appeared in UEditor devices list OK. Created all environment variables, filled in android SDK paths in UEditor Started Package Project-> Android ETC1 and after a while got a failure.

alt text alt text Buildlog , UnrealBuildToolLog

Product Version: UE 4.9
Tags:
more ▼

asked Dec 16 '15 at 04:28 PM in Packaging & Deployment

avatar image

Snowwolf
33 3 6 7

avatar image Matthew J Dec 17 '15 at 08:37 PM

Hello Snowwolf,

I have a few questions for you and a couple things to try.

  1. Have you tried any other versions of the editor? If not, could you give 4.10.1 a try? Multiple fixes around Android packaging went in with the 4.10 builds.

  2. Have you tried a Blueprint project just to see if the issue still occurs?

  3. When you mention you made an "empty new mobile C++ project", did you base this project off any of the templates? This could help in trying to reproduce the issue on our end.

  4. Can you try changing the "SDK API Level" to "latest" and also packaging for "Android - All" or ETC2?

avatar image Snowwolf Dec 19 '15 at 11:33 AM

Hello Matthew!

  1. I'll Try to package with 4.10.1 from Launcher, maybe today.

  2. I tried to create a Blueprint project at first, it fails the same way.

  3. I created an empty blank C++ project with No starter content in it. Specified it as a "Mobile/Tablet" project.

  4. Tried to set SDK API level to latest - same result. Have not tried yet "Android - All" or ETC2.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Installed TADP 3.0r4 Installed 4.10.1 from Launcher, Created empty blank Blueprint project set to Mobile/Tablet Specified paths to Android SDK, NDK, Apache ant, JDK packaged successful for Android ETC1 Thanks!

more ▼

answered Dec 20 '15 at 10:46 PM

avatar image

Snowwolf
33 3 6 7

avatar image ryuikuya Dec 30 '15 at 08:57 AM

DId u Installed TADP 3.0r4 with full or custom depence?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question