x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cook Failure

When I try to package my project, it fails with this message: PackagingResults:Error: Error Unknown Cook Failure.

I have pasted the log to .txt file. There are many warnings but which exactly can be preventing the success of packaging?

link text

Product Version: UE 4.9
Tags:
cook failed.txt (1.7 MB)
more ▼

asked Dec 16 '15 at 08:13 PM in Packaging & Deployment

avatar image

tongucci
59 16 24 27

avatar image Adam Davis STAFF Dec 16 '15 at 09:33 PM

Hi tongucci,

  • What device are you packing for?

  • Is this a shipping or development build?

  • What steps are you taking to package your project?

  • Is this a c++ or blueprints project?

avatar image tongucci Dec 17 '15 at 11:11 AM

Hi,

  • I am packing for Windows (tried both 64 bit and 32 bit, same result).

  • Development build.

  • I'm clicking File Menu - Package Project - Windows - 64-bit (or 32)

  • It is a blueprints project.

Something important: There is Luos Caves asset package in my project and when I package the latest backup (I make backups everyday) before adding that package to my project, it successes packaging.

Also can be important, I also tried: Create a new first person project from scratch with no starter content, packaged it, it was successful, just added Luos Caves asset package to my project, then tried to package my project, failed and gave me the result that now I am attaching.link text

cook failure.txt (5.1 MB)
avatar image tongucci Dec 17 '15 at 01:06 PM

Same issue happens when creating a new project in 4.8 or 4.10 and adding Luos Caves to project. I'm sending their logs by here.

link text

link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello Tongucci, If you press "CTRL + F" in that log, you can find the following error:

LogBlueprint:Error: [compiler FirstPerson_AnimBP] Error Play FirstPerson_Idle references sequence that uses different skeleton FirstPerson_Skeleton

So in this case its a skeleton related error.

more ▼

answered Dec 17 '15 at 05:46 PM

avatar image

Luos
9.2k 283 63 330

avatar image tongucci Dec 17 '15 at 07:31 PM

I have migrated my level to a new 4.10 project and finally packaged. The issue obviously has nothing to to with Luos Caves package. Still you helped me Luos, thanks a lot!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Tongucci,

Luos from the cavepack here. The warning states this:

"MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.12.17-10.44.29:235][ 0]LogLinker:Warning: Asset '../../../../../../Users/Tonguc/Documents/Unreal Projects/test2/Content/LuosCaves/Meshes/Props_Nopal_rocks/SM_LCave_P_Free2_Nopal_Rock_45.uasset' has been saved with engine version newer than current and therefore can't be loaded. CurrEngineVersion: 4.9.2-2707645+++depot+UE4-Releases+4.9 AssetEngineVersion: 4.10.0-2758231+++depot+UE4-Releases+4.10"

Meaning the version of the cave you used, was newer than the engine version you used.

Looking at the 4.10.1 build log, I found this error:

" Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Core\Public\Serialization\Archive.h] [Line: 96] MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: FMemoryWriter does not support data larger than 2GB. Archive name: C:/Users/Tonguc/Documents/Unreal Projects/test4101/Content/Maps/LCaves_Mesh_Showcase.umap."

And, I dont know what that problem is. Since you dont need the showcase map, you could delete it. But I am sure someone else can explain why the error occurs. It should not have anything to do with the cave pack itself.

more ▼

answered Dec 17 '15 at 01:28 PM

avatar image

Luos
9.2k 283 63 330

avatar image tongucci Dec 17 '15 at 04:12 PM

Thanks Luos. I created new 4.10 project and added Caves, then deleted all showcase maps. Only then packaging was successful. Even deleting showcase maps on a 4.9 project didn't make it so. Now I will migrate my actual project to 4.10 and try again.

avatar image tongucci Dec 17 '15 at 05:36 PM

I have migrated my project to 4.10.1. Deleted all the showcase maps from content. Then tried to package my project for Windows 64 bit. Failed again. Here is the log.

link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question