x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HELP cannot operate with my project

First of all, let me say this is not a side project, or something I can copy paste and start again, this is my final degree project and it's a month from its deathline so please take into acc this is important to me.

I'm developing it using blueprints with UE4.9.2.

Couple of weeks ago I started expanding the level design (was using topdown template level). After a little I ran into a crash which didn't let me open the project. Searching here in answerhub I found and answer worth trying out:

  • Delete intermediate and saved folders (obviously creating a backup copy before) and also (if needed) the config folder.

After doing so, I was able to open my project again, due to .ini files erase I started the project not in the level I was developing but in an untitled template. This didn't bother me, I could still open the level afterwards and keep on.

Not long after that the editor started crashing when I opened the level and faced serious freeze issues (about 3-4 sec freeze) the first time I tried to open/right-click a blueprint. But I discovered that after opening a datatable object and right-clicking a simple blueprint the editor seemed to awake and let me open everything as normally expected.

Problem is: right now I can open the project, I can open datatable / struct / enum / meshes materials and all the simple stuff. But as soon as I try to open a blueprint o right click on it or hit play (and not to mention, trying to change level) the editor crashes.

I can provide any kind of logs / pc build / any_random_stuff_you_need_to_help_me_out, but please if you have a shade of knowledge about what could be happening, please, I beg you to help.

I invested a lot of time, effort and illusion into this, but I'm sure you all know how I feel.

Waiting for response, thank you in advance

Product Version: UE 4.9
Tags:
more ▼

asked Dec 16 '15 at 08:38 PM in Bug Reports

avatar image

necrobooder
13 1 3 6

avatar image Rudy Q ♦♦ STAFF Dec 17 '15 at 05:22 PM

Hello necrobooder,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps in order to reproduce this issue on our end?

  3. Could you provide the crash log that is given when your issue occurs?

  4. If you create a new clean project and migrate the blueprint(s) that are causing issue one at a time are you able to open them up that way to make changes that may allow you to open the blueprint up in your original project?

avatar image Rudy Q ♦♦ STAFF Dec 21 '15 at 02:46 PM

Hello necrobooder,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image necrobooder Dec 22 '15 at 11:35 AM

Actually it isn't solved yet, I was planning on reseting my entire computer this week (been busy with other latter year delivers). I'll be providing more information later this week, but answering your questions:

1- NO, with a new project (even with any of the others I had created) it does NOT reproduce. It seems to me like the editor (or my CPU/RAM/HD) are not fast enough loading assets, and some timeOut makes the engine crash.

2- --

3 - I'll provide them if the fresh windows + engine install does not solve it (which I don't actually expect to)

4 - I haven't tried that, I tried migrating the entire content folder to a fresh UE10.2 project and it didn't work. (DataTables / enums / structs can always be opened, the issue is only with blueprints and levels)

Sorry for not replying before, december is a very busy month with exams and everything. Thank you for replying and I'd prefer this answer not to be flagged as resolved.

Again thank you, expect news very soon.

avatar image Rudy Q ♦♦ STAFF Dec 23 '15 at 07:23 PM

Please be sure to update this thread with any additional information you gather and I will be happy to assist you further.

avatar image necrobooder Dec 28 '15 at 06:59 PM

Hi there again,

I did a clean windows install, full ue4 9.2 clean install and tried again with no success.

So far I did the following and I think it might help you reach what the problem is about: (side note: i've been keeping the project as it is and working on an exact copy to test things)

When I remove a struct that is used in some blueprints (in my case I use a 'description' which every in-game character gets from a datatable object during the construction script) and I right-click a blueprint in the content browser (which used to crash the editor) the editor keeps a couple of seconds 'thinking' and then prompts a dialog as seen in the attached image. After canceling every dialog, the game works as it should (just that blueprints don't compile due to the removal of the struct).

alt text

Let me say that, as I previously stated that the project crashes when I attempt to open or right click a blueprint in the content browser (or when I hit play or try to open the level blueprint menu). Using this method it seems that the editor 'reacts' to something before crashing so it gives enough time to itself to actually open the blueprints.

Finally, let me attach a log of one of the crashes with the untouched project version.

Thanks again for you help!

link text

crashlog.zip (76.3 kB)
ue4-message-01.png (149.5 kB)
avatar image Rudy Q ♦♦ STAFF Dec 29 '15 at 05:01 PM

Could you provide the project that you are having issues with so that I may take a closer look? You can provide the project via dropbox or google drive if the file is too large to attach to this thread.

avatar image necrobooder Dec 29 '15 at 05:11 PM

its 7GB (I loaded in a lot of assets and planned to do a clean up later) it is currently uploading to dropbox, so once it is done (my internet connection is very low) I will post a reply with the link.

Thank's!

avatar image Rudy Q ♦♦ STAFF Dec 30 '15 at 05:36 PM

After digging through your project I found that there is an invalid type in one of your structures. If you look in "ItemInfoStruct" you will see that there is a member that has an error. I removed this and cleaned up the other errors in Main_Character, BaseItem, AbilityBase, NPC, DataManager, IATGameMode, EnemyBase, ShadowStep, and CharacterHUD. After I was able to successfully compile all of these blueprints I was able to avoid any sort of freezing or crashing. Could you try this and let me know if this works for you?

avatar image necrobooder Dec 30 '15 at 07:23 PM

I'm afraid I wrongly uploaded the version in which I had already removed the struct to force it work. So the problem I mention cannot be reproduced in the version you tried.

To do so, please, insert the blueprint in the link below in Content > TopDownBP > Blueprints > Data.

https://www.dropbox.com/s/qh6dbffvmcqonjr/DescriptionStructFinal.uasset?dl=0

Sorry for the inconvenience, and thank's again for your dedication.

avatar image necrobooder Jan 05 '16 at 12:01 PM

I'm aware you may be in vacation, but just in case you are not and this post was left behind by accident, let me comment again to ping it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello necrobooder,

I have ran a few tests with the asset that was provided. After digging through the project and removing most of the content I was able to narrow things down enough to fill out a report (UE-25009) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered Jan 06 '16 at 07:37 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image necrobooder Jan 06 '16 at 07:55 PM

Thank you so much.

Waiting for your response (i'm now 22 days from the deadline, so very impatiently wait :) )

avatar image necrobooder Jan 17 '16 at 12:38 PM

Are there any news?

avatar image Rudy Q ♦♦ STAFF Jan 18 '16 at 02:11 PM

Hello necrobooder,

I went ahead and double checked on this issue for you and it appears as though the status for this issue has not been updated to fixed as of yet.

avatar image necrobooder Feb 04 '16 at 07:59 PM

Hello again Rudy, any news on this issue? Any way I can check it myself?

Thanks a lot

avatar image Rudy Q ♦♦ STAFF Feb 04 '16 at 08:04 PM

Hello necrobooder,

I checked on the report for this issue, and the status remains unchanged as of this time. As for a way that you could check yourself, the tracking system is not public. However, I will be happy to provide updates when they are available.

avatar image necrobooder Feb 04 '16 at 08:08 PM

That was a quick answer sir, Thank's for your job, I have presented my project today and it is no longer an urgent issue. But I plan to continue it whenever I have the chance. Do you think (totally personal opinion) I will be able to fix the bug? or the developers will most likely give a reason but not a solution? Thank you again

avatar image Rudy Q ♦♦ STAFF Feb 05 '16 at 01:37 PM

I am sure that the developers will do their best to provide a solution when possible.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question