x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Crash] Rendering thread exception: Fatal error!

Hi all,

I've encountered an issue within my project whereby the game crashes to desktop under repeatable circumstances. A quick look at the log file shows this:

 [2015.12.17-15.49.08:513][636]LogWindows:Error: === Critical error: ===
 Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 675] 
 Rendering thread exception:
 Fatal error!

I'm not really sure of what it means by "Rendering Thread Exception" or how to respond to it, but it's causing my game to crash in the same place pretty reliably. The crash occurs in the main menu, after selecting a specific menu item, but it only occurs if the user has returned to the main menu map from the game map; it doesn't seem to happen on the first visit to the menu.

Another notable thing is that the problem never occurs in PIE. It occurs in packaged builds, or using the "Standalone Game" option.

I have attached the log file and crash dump here.


Any help on this would be greatly appreciated,

Ben

Product Version: UE 4.10
Tags:
logs.zip (49.4 kB)
more ▼

asked Dec 17 '15 at 04:37 PM in Packaging & Deployment

avatar image

zerofiftyone
204 26 28 93

avatar image 박종찬 Jan 13 '16 at 08:49 AM

I'm struggling with the same error. Any clue did you find out??

avatar image zerofiftyone Jan 13 '16 at 01:19 PM

Nope, no solutions yet. The only related thing I can find in the logs is a warning that appears before the crash that says:

 LogLinker:Warning: CreateImport: Failed to load Outer for resource 'WidgetTree': WidgetBlueprint /Script/UMGEditor.Default__WidgetBlueprint

I don't know exactly what that means though; or if it's even related to the crash.

avatar image 박종찬 Jan 14 '16 at 06:44 AM

I don't think It's related to it. I found something very strange. My game works fine after rebuild light-map. I have no idea why does this fixed the bug... but it seems like temporary measure. Now I'm in the fear of when the bug coming back to appear again because it appears sometime and goes after rebuild light-map / geometry / navigation

avatar image zerofiftyone Jan 14 '16 at 01:05 PM

That's interesting! Unfortunately it doesn't work for my project. To clarify, are you talking about building using this button:

alt text

So has it fixed the issue for you, or is it still too early to tell?

avatar image Matthew J Jan 15 '16 at 09:29 PM

Hello zerofiftyone,

Did you ever submit the crash report that you got (if you got one) to us? I'm having trouble finding it. Unfortunately the logs don't include everything and the minidump won't give the callstack without the source available.

If you never did, could you please reproduce the crash and send the report and then let me know? I should be able to look it up and may be able to find other occurrences and possibly a fix.

avatar image zerofiftyone Jan 15 '16 at 11:10 PM

Hi Matthew,

I think I must have done so, but I can do so again right now for you.

EDIT: Done! Just reproduced the crash and sent off the bug report.

alt text

avatar image Matthew J Jan 18 '16 at 04:48 PM

Ah, well that would make sense. Our system won't log it if there isn't a callstack to go along with it so it isn't showing up for that reason.

Seeing as that the crash message isn't telling me much, I'll be looking into this further and I'll let you know when I have more information. Thank you for making sure that crash report got submitted either way.

Edit: I never asked this previously but it could be important. Is there a separate level for your Main Menu or is it a UMG that comes up over the game level? What is the "specific menu item" that causes the crash? If it's one that changes the level, do you ever see the new level before the crash occurs?

avatar image Matthew J Jan 25 '16 at 08:57 PM

Hello zerofiftyone,

I'm leaving this comment to let you know that I'm still looking into the issue. In the meantime, could you answer the questions I asked in my previous comment?

avatar image zerofiftyone Jan 25 '16 at 09:56 PM

Ah, hello. I didn't see the edit!

The Main Menu is a separate level. The menu item that causes the crash is the "Start Game" menu, which opens another menu and doesn't change the map upon being selected.

avatar image Matthew J Jan 28 '16 at 08:15 PM

Thank you for the reply. While you've been very helpful with providing information, we still don't have much information due to the lack of a callstack and how general "Rendering Thread Exception" is. It could be many different things.

Would it be possible to get a copy of the project that this issue is occurring in? If so, and you want to keep it private, you could send a link to the download to me via a private message on our forums. Here is a link to my profile.

If you're not able to provide a copy for any reason, please let me know and we'll find another way to continue.

avatar image zerofiftyone Feb 02 '16 at 09:46 AM

I'll get a slimmed down version of the project uploaded for you soon.

Thanks, Matthew.

avatar image Matthew J Feb 05 '16 at 08:51 PM

Thank you for the project, zerofiftyone. I've actually not been able to reproduce the exact crash you're getting. I've had a couple others that were intermittent such as the first time I tried to input something during the game and one time when transferring to the difficulty selection. The only thing that stands out is that the plugin FMod (I believe that is what it was called) was not included in the project and that had to be deactivated for me to launch it. Could you try removing this plugin and seeing if it was what was causing the problem?

avatar image zerofiftyone Feb 10 '16 at 04:36 PM

The crash that occurs when transferring to the difficulty selection is the one I'm referring to.

The FMOD plugin can be ruled out I think, as it was added to the project only very recently; after the crashing issues had already started.

avatar image Matthew J Feb 15 '16 at 04:27 PM

After crashing and looking at the log, I noticed that it gets absolutely flooded with messages about an array going out of bounds. Seeing as multiple of these messages are related to GetAllWidgetsOfClass, this could be related to the crash as it is occurring when the widgets for the difficulty selection are suppose to appear. Could you check up on your arrays and ensure that they stay within bounds?

Heres an example of one:

LogScript:Warning: Attempted to get an item from array CallFunc_GetAllWidgetsOfClass_FoundWidgets out of bounds [0/0]! LogScript:Warning: Accessed None 'K2Node_DynamicCast_AsW_Score' W_GameOver_C /Engine/Transient.GameEngine_0:BP_GameInstance_C_0.W_GameOver_C_0 Function /Game/UI/In-Game/W_GameOver.W_GameOver_C:Get_NewHighScore_Visibility_0:00F3

avatar image Matthew J Feb 22 '16 at 01:32 PM

Hello zerofiftyone,

Have you had a chance to look into the problem I presented in my previous comment? I'd be interested to know if you've found any problems with your arrays that could be causing this crash.

avatar image Dannington Jan 25 '16 at 09:14 PM

Hi Matthew - same crash description as zerofiftyone, but unable to put a finger on what the problem is - other than if I slow down the system by pushing up the resolution etc it crashes less. There are no widgets in use but I have a safe-frame overlay which is set up in the background. My 'game' is actually a realtime results system for a TV gameshow - we're hoping for worldwide sucess, but at the moment the first area to use the format is a company in Beirut - the show's called 'Ask The Arabs' link text and it goes out to 22 countries live!

You can see from the video (if you like) that it's a really simple system but it's a bit embarrassing when it crashes in front of 15 million viewers! (There's a backup system working in tandem, and they don't crash simultaneously - which is all the more confusing as the systems are exact clones)

I'm using 3 plugins: Blui - which renders the arabic text for me in HTML windows. Rama's Victory Plugin - Which loads text files A socket TCP listener which Rama wrote.

Anyway attached is my crash report - take a look.

Thanks

Dan

link text

crashcontext.zip (37.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

We haven't heard from you in a while, zerofiftyone. Are you still experiencing this issue? If so, have you taken a look at my previous comment to see if that could be the issue? Otherwise, it would be great to know how to you fixed it. In the meantime, I'll be marking this as resolved for tracking purposes.

more ▼

answered Feb 26 '16 at 01:47 PM

avatar image zerofiftyone Mar 17 '16 at 12:48 PM

Hi Matthew. Sorry for the delay. I just wanted to let you know that I experimented with moving the project onto 4.11 Preview and the crashing issue seems to be completely absent now.

I still never got to the bottom of what exactly caused it initially which is a shame, but I would advise anyone else in the same position to try moving to 4.11 if they're able to.

Thanks for all your help with this!

avatar image Matthew J Mar 17 '16 at 06:07 PM

Glad to hear that the issue was fixed. If it does present itself again, please let me know and I'll be happy to take another look.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having render thread crashes on an application I've been working on recently to the point where I was really despairing. What was weird was I started to optimise my blueprints and simplify my textures but the crashes became more frequent. In the end I realised the engine seemed to be running too fast! When I switched to a higher resolution and over cranked the screen percentage to 200% my crashes stopped. My application is very simple in terms of textures and geometry.

more ▼

answered Jan 19 '16 at 06:50 PM

avatar image

Dannington
113 5 9 16

avatar image zerofiftyone Jan 19 '16 at 07:07 PM

That's really odd! I guess it's not a proper fix, but I'll try replicating that out of interest.

avatar image Dannington Jan 23 '16 at 07:32 PM

Any news there zerofiftyone? I'd love to know if anyone else is experiencing this.

avatar image zerofiftyone Jan 23 '16 at 10:41 PM

Sorry about the delay; I've spent most of the week off work with a back injury :(.

Anyway, I replicated your suggestion and it didn't work the same way. It actually made the crash occur more frequently, so that's weird too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question