x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR not working with Oculus UDK 1

I'm trying with both 4.10 and 4.9 to do the following: https://docs.unrealengine.com/latest/INT/Platforms/Oculus/QuickStart/5/index.html

I've verified that Oculus is all set up (I can run it in Unity, and I did the showlog ovrversion verification).

When I try to run the VR mode, all I see is a black screen on the computer and all black through the Oculus. I noticed the ContentExamples project has the camera just pointing off into blackness, but if I move it into the lit room in front of the statue, it crashes when I try to play.

I also try with a 4.9 project and that crashed too when I tried to run it.

I also tried running the standalone version instead of VR, then using alt + enter to go fullscreen for VR, and that crashes the game too.

Product Version: UE 4.10
Tags:
more ▼

asked Dec 17 '15 at 06:04 PM in VR

avatar image

summitch
13 1 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

Using Alt+Enter, full screen, "clone desktop mode" not work anymore. You need install last version of Oculus SDK 0.8.0.0 and install last version of nVidia drivers, which contain official GameWorks VR support.

more ▼

answered Dec 18 '15 at 11:27 AM

avatar image

svv3dUDN
8.4k 254 41 399

avatar image summitch Dec 19 '15 at 04:50 PM

I've reinstalled my NVidia drivers and this still didn't work (I have the latest Oculus SDK and a brand new machine).

I was able to get it to work by forcing Unreal to use the integrated graphics card, but it lowered its playback quality because the frame rate was so low, and now, I can't get it to render and high quality anymore (even when set back to use the NVidia card).

avatar image svv3dUDN Dec 21 '15 at 12:33 PM

Last version of UE4 Editor launches standalone game with parameter -nohmd. You can launch your VR project in two ways. The first way - use VR Preview in Editor. The second way - create package game for the Windows and launch it in the standalone mode. These both ways work for me.

If you add to level blueprint this node, then your project always will run in VR mode

alt text

vr01.png (38.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question