x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Significant FPS drop after 4.1 patch

I've updated to 4.1 and the editor is basically unusable. The editor became extremely slow and it's impossible to use it, even in the lowest quality preset.

If I switch back to 4.0.2 the editor works just fine. So, it's not my computer.

Can you please verify this?

Product Version: Not Selected
Tags:
more ▼

asked Apr 25 '14 at 04:20 PM in Bug Reports

avatar image

rodrigo.lima
8 2 5

avatar image Konesoft Apr 25 '14 at 04:50 PM

Works perfect ! thanks

avatar image amigo Apr 25 '14 at 04:55 PM

I noticed a significant slowdown as well, on my Mac here, although I did not try 4.1 in Windows, there is a difference between 4.1 and 4.0.2.

avatar image RobertRamsay Apr 25 '14 at 05:31 PM

Same, task manager (windows) shows a not responding every now and then, whenever 4.1 is asked to do somethhing.

avatar image RinDreamX Apr 25 '14 at 05:32 PM

I got the same problem in my Surface 2 Pro. It seems that UE4.1 had the tendency to not select anything that's "Intel..." graphic adapter. This is ok in many cases, but it backfire on my little machine where the selection is a software renderer instead. I'm still looking for ways to switch it back to use my intel HD graphics. If any of you guys found out, please update. Thanks in advance. alt text

snipimage.jpg (36.8 kB)
avatar image RobertRamsay Apr 25 '14 at 06:24 PM

Perfect, thanks: alt text

4-1patch.jpg (428.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Your are right, Sorry. We will fix that soon.

The workaround: put this into Consolevariable.ini: r.GraphicsAdapter = -2

Please respond so we know that fixed your issue.

more ▼

answered Apr 25 '14 at 05:52 PM

avatar image Adam Davis STAFF Apr 25 '14 at 05:55 PM

Hi everyone,

Martin already posted the fix here, if you are still having trouble please report this to this page:

https://answers.unrealengine.com/questions/34906/epic-official-read-this-if-you-are-experiencing-fp.html

We want to make sure we get everyone who is still having trouble a fix as quickly and efficiently as possible. Thank you!

avatar image rodrigo.lima Apr 25 '14 at 06:04 PM

Works perfectly! Thanks!

avatar image Konesoft Apr 25 '14 at 06:14 PM

I still having the same trouble after doing this =( another fix ? (Do i have to put r.GraphicsAdapter = -2 at the last line of the .ini file ?)

avatar image rodrigo.lima Apr 25 '14 at 06:20 PM

The file should be at:

C:\Program Files\Unreal Engine\4.1\Engine\Config\ConsoleVariables.ini

You should place the line in a new blank line after the last line in the file. Some thing like this:

;r.ShaderDevelopmentMode=1

r.GraphicsAdapter = -2

Be sure to restart the editor.

avatar image Konesoft Apr 25 '14 at 06:30 PM

Works really really perfect thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I got the reply from Nick Penwarden. This allowed me to select my Intel HD as D3D11 Device instead of the software: My test level FPS up from 1-3FPS to 70FPS on Low Quality and 20FPS on Epic Quality. Just like the old UE4.0.2 Big thanks.

Add these lines to MyProject\Config\DefaultEngine.ini

[SystemSettings]

r.GraphicAdapter=-2

Here's the snipped on the log after the changes:

LogD3D11RHI: Found D3D11 adapter 0: Intel(R) HD Graphics Family (Feature Level 11_0)

LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 1792MB of shared system memory

LogD3D11RHI: Found D3D11 adapter 1: Microsoft Basic Render Driver (Feature Level 11_0)

LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 256MB of shared system memory

LogD3D11RHI: Chosen D3D11 Adapter Id = 0

more ▼

answered Apr 25 '14 at 06:16 PM

avatar image

RinDreamX
88 9 12 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question