x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why can't I open c++ projects after 4.1 patch on Mac OSX?

I just purchased UE4.1 I started the launcher, picked Launch, picked New Project, Selected "Code First Person". This launched XCode. It picked the mac project and picked run. A few minutes later the editor starts. I picked Save, then exited the editor.

Now from the Launcher I pick "Launch". I see "MyProject" and select it. Pick Open. I get

"The game module 'MyProject' could not be found. Please ensure that this module exist and that it is compiled"

I've tried 3 times now. No luck.

Product Version: Not Selected
Tags:
more ▼

asked Apr 25 '14 at 04:27 PM in Bug Reports

avatar image

greggman
1 2 2

avatar image Stephen Ellis ♦♦ STAFF May 09 '14 at 12:38 PM

Hi greggman, apologies for the delayed response.

Have you tried to recompile your project in Xcode? Did it help?

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi greggman. When you first created the project and it opened in XCode, did you change the Build Configuration for the build from DebugGame to Development? If you leave it in DebugGame, you will have to open the project in XCode and build it every time in order to be able to open it in the UE4 Editor. If you change the Build Configuration to Development, you will be able to open the project directly from the list of your projects after launching the Editor.

In order to check what Build Configuration you have set for your XCode project, go to Product->Scheme->Edit Scheme. In the window that appears, make sure your Build Configuration is set to Development. Please let us know if that helps with the issue you are experiencing.

Thanks.

more ▼

answered May 09 '14 at 02:34 PM

avatar image greggman May 10 '14 at 08:47 AM

No that didn't help. In fact it made it worse. Here's a video of me starting from scratch All I do is create a new project, xcode starts, there's no instructions on what to do next so I pick run. I get errors. I switch the target to Mac, get errors, switch the target to editor mac, it runs, move one thing, save, quit, quit xcode, from launcher launch the editor, pick the project I just saved. Get error.

Right after I made the video I tried your way. I started from scratch again, made a new project "MyProject4", selected the mac editor target, change the build configuration from DebugGame to Development, press run, it compiled, launched and immediately gave me this error

avatar image Tim C ♦♦ STAFF May 10 '14 at 01:05 PM

Hi greggman. It is unusual for a project to throw up that error message on the very first compile. I will see if I can get access to a Mac today and try to reproduce that.

avatar image Tim C ♦♦ STAFF May 10 '14 at 02:10 PM

Hi greggman. I was not seeing that error message yesterday, but I did get it today when I created some new code projects and compiled them in XCode. However, I tried opening those new projects through the Unreal Editor after I received that error message and they opened fine, and appeared to function normally. I even added some additional class files to the project and recompiled in XCode and everything seemed to work fine after that initial error message. I will have one of our developers look into this further on Monday to see if we can determine what is triggering that initial error message.

In the meantime, could you please try using the Unreal Editor to open one of the projects you have already created (using the Development build configuration) and let us know if you still see the same error message, or if the Editor successfully opens the level for you.

Thanks.

avatar image Tim C ♦♦ STAFF Jun 13 '14 at 10:04 PM

Hi greggman,

We have not heard back from you in a while, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with any additional information you may have and we will offer further assistance.

Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question