x

Search in
Sort by:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Epic Official] Read this if you are experiencing FPS drops after the 4.1 patch

My editor FPS rate has dropped after the 4.1 patch

If you are experiencing a frame-rate drop since the 4.1 patch was deployed.

Please refer to this post as the official Epic response to this issue. We will keep this top post updated with the current information and potential solutions regarding this issue. Please do not attempt potential fixes provided in other posts, as they are most likely out-of-date. If you are still experiencing the issue after trying any potential solutions recommended below, please post a single "Answer" to this post with the information that we request. If you need to provide additional updates, please only "Comment" on your original Answer.

Thank you for your patience while we work to address this issue. As new solutions become available we will update this post.


SOLUTION #1:

The fix will be in a future version of the launcher, but for now, you can edit Consolevariable.ini to change the console settings that may be the cause of the issue.

  1. Go to: C:\Program Files\Unreal Engine\4.1\Engine\Config

  2. Put this into Consolevariable.ini:

r.GraphicsAdapter = -2


SOLUTION #2:

If the first solution does not help, please download and follow the QFE instructions from here:

https://forums.unrealengine.com/showthread.php?3147-Current-Available-Quick-Fix-Solutions


Please let us know if this does not solve your framerate drop. Thank you!

Tags:
more ▼

asked Apr 25 '14 at 05:48 PM in Bug Reports

Adam Davis gravatar image

Adam Davis ♦♦STAFF
19.3k 415 6 109

Konesoft gravatar image Konesoft Apr 25 '14 at 06:09 PM

Works perfect ! Thanks

ShadowKindGames gravatar image ShadowKindGames Apr 25 '14 at 09:01 PM

Made things worse for me. I can get on average 45 - 50 FPS on a GTX 780 with an I7 3770K 16GB DDR on the effects cave. I'd be interested to hear what others are getting because whilst it runs fine on top of the range hardware I'd dread to thing of what it would run like on a GTX 750. I played with engine scalability the only thing that made any difference was dropping shadows to low. That added 8 FPS.. I couldn't release a game to the public with minimum specs a GTX 780TI.

Luos gravatar image Luos Apr 25 '14 at 09:02 PM

Not working for me, still a loss of 20 fps between my 4.02 and 4.1 version of the project (both identical)

The suggestion made by Rin also failed to show any increase in performance. I really hope that this will be sorted because 20 fps is a rather big drop :( Good luck finding the issue! :)

Edkenway gravatar image Edkenway Apr 25 '14 at 09:58 PM

Worked for me! Thanks!

Adam Davis gravatar image Adam Davis ♦♦ STAFF Apr 25 '14 at 10:17 PM

Hi luos,

Could you provide us with your dxdiag so we could have a look? Thank you!

Luos gravatar image Luos Apr 26 '14 at 02:32 AM

Uhm.. Would you mind explaining how to do this? Also, is there a max fps in ue4? If it changed from 120 to 100 fps that might have been the issue? I tried t.maxfps to 120 but that didn't help.

Edit: https://www.dropbox.com/s/tvy8flwegw6ql4w/DxDiag.txt

DarkInfiktrator gravatar image DarkInfiktrator Apr 26 '14 at 04:51 PM

Everything runs at 8 FPS for me now (core i7 -3610QM, 8GB DDR3 and GTX 660M) before everything ran at 45+ FPS, Elemental Demo runs at MINUS 150 FPS for me and even crashes my PC for hours. I tried your method in Consolevariable.ini, before I had : ; ConsoleVariables.ini ; ; This file allows to set console variables on engine startup (In undefined order). ; Console variables also can be set in engine ini files (e.g. BaseEngine.ini, DefaultEngine.ini) in the [SystemSettings] section. ; This file should be in the source control database (for the comments and to know where to find it) ; but kept empty from variables. ; A developer can change it locally to save time not having to type repetitive ; console variable settings. The variables need to be in the section called [Startup]. ; Later on we might have multiple named sections referenced by the section name. ; This would allow platform specific or level specific overrides. ; The name comparison is not case sensitive and if the variable doesn't exists it's silently ignored. ; ; Example file content: ; ; [Startup] ; FogDensity = 0.9 ; ImageGrain = 0.5 ; FreezeAtPosition = 2819.5520 416.2633 75.1500 65378 -25879 0

[Startup]

; Uncomment to get detailed logs on shader compiles and the opportunity to retry on errors ;r.ShaderDevelopmentMode=1

Then I added r.GraphicsAdapter = -2 nothing happened(maybe even worsened)

then I changed to [SystemSettings]

r.GraphicAdapter=-2

Same thing

then I did add ";" ;[SystemSettings]

;r.GraphicAdapter=-2

Same, thing. Which is the correct form please? with adding [SystemSettings] or not and with adding ; or not? Thanks.

Cirych gravatar image Cirych Apr 26 '14 at 07:36 PM

Problem solved. Thanks!

Try on integrated HD4600, without any other video cards.

giggs129 gravatar image giggs129 Apr 30 '14 at 10:05 PM

Hi

Im also experiencing huge framerate drops. I struggling to run the engine along with any of the example maps with an average speed of 3-5fps. I have tried adding the suggested line above and also ran QFE but no luck.

I have attached dxdiag and any advice would be greatly appreciated.

Regards
Chris

link text

dxdiag.txt (95.1 kB)
Stephen Ellis gravatar image Stephen Ellis ♦♦ STAFF May 01 '14 at 08:41 PM

@giggs129

Can you please tell us what your average fps was in 4.0.2 for comparison? Thanks

giggs129 gravatar image giggs129 May 03 '14 at 12:36 AM

Hi Stephen

My average FPS in 4.0.2 was anywhere between 50-70fps depending on which map I was loading.

However after going back the framerate now in 4.0.2 has also dropped to 3-5fps. The launcher app is also running sluggish in terms of fps and Im not sure what has happened for the FPS to suddenly drop so alarmingly.

I have tried uninstalling everything including the example projects but again that made no difference.

Thanks

Stephen Ellis gravatar image Stephen Ellis ♦♦ STAFF May 04 '14 at 01:56 PM

@giggs129

I notice that you have two video cards in your system. Can you confirm on your Nvidia control panel that UE4 is using the GTX 780M and not the HD Graphics 4600?

Thanks

master_rigel gravatar image master_rigel May 04 '14 at 01:15 AM

My problem is a little bit different. My framerate is "fine". That is to say that the ability to render frames to the screen is not a problem. What is a problem is how many frames reflect my mouse position and mouse input. I will move my mouse a normal amount and the cursor will not move at all. Or! I'll move the mouse a normal amount and the cursor will move a normal amount but it will jump from one position to another. Finally mouse clicks will be missed or delayed. Panning the screen will cause drops as the mouse position is updated. It all seems to come back to mouse input.

I can confirm this because keyboard input is flawless. No dropped frames, no dropped input, no dropped keystrokes. I've double checked this via diagnostic tools to find out what's registering and what's not.

When I ran NVIDIA diagnostics, it didnt' show any more activity on the card with UE 4.1 running than with it not running. At least UE 4.02 showed SOME activity, but still allot of that activity was showing up on my integrated graphics.

DX Diagnostic also shows that multi-threading is completely broken. While the processor is running on multiple threads, my graphics are not. My graphics are running entirely on one thread for the launcher and one thread for the editor. This is not good. My NVIDIA GTX 750 is multi-threaded however my NVIDIA integrated grpahics are extremely limited.

I've attached the DX Diagnostic

link text link text

dxdiag32.txt (29.6 kB)
dxdiag64.txt (40.4 kB)
Stephen Ellis gravatar image Stephen Ellis ♦♦ STAFF May 04 '14 at 02:51 PM

@master_rigel

If you have tried the solutions posted here to no effect, then it sounds as if you have a separate issue from the majority in this post, and I would like to focus on it individually. Can you please repost everything you provided as a new question on the AnswerHub?

Thanks

Vishahan gravatar image Vishahan May 12 '14 at 03:58 PM

If anyone still has the issue with the code thingy, here is a copy of my contents of ConsoleVariables.ini which worked for me, even though the instructions were pretty clear. :D ; ConsoleVariables.ini ; ; This file allows to set console variables on engine startup (In undefined order). ; Console variables also

 can be set in engine ini files (e.g. BaseEngine.ini, DefaultEngine.ini) in the [SystemSettings] section.
 ; This file should be in the 
 
 source control database (for the comments and to know where to find it)
 ; but kept empty from variables.
 ; A developer can change it 
 
 locally to save time not having to type repetitive
 ; console variable settings. The variables need to be in the section called 
 
 [Startup].
 ; Later on we might have multiple named sections referenced by the section name.
 ; This would allow platform specific or 
 
 level specific overrides.
 ; The name comparison is not case sensitive and if the variable doesn't exists it's silently ignored.
 ;
 ; 
 
 Example file content:
 ;
 ; [Startup]
 ; FogDensity = 0.9
 ; ImageGrain = 0.5
 ; FreezeAtPosition = 2819.5520 416.2633 75.1500 65378 -25879 0
 
 [Startup]
 
 ; Uncomment to get detailed logs on shader compiles and the opportunity to retry on errors
 ;
 r.ShaderDevelopmentMode=1;
 r.GraphicsAdapter = -2
(comments are locked)
10|2000 characters needed characters left

7 answers: sort voted first

Hello everyone,

I am marking this as accepted for tracking purposes.

more ▼

answered Jun 25 '14 at 06:25 PM

Adam Davis gravatar image

Adam Davis ♦♦STAFF
19.3k 415 6 109

(comments are locked)
10|2000 characters needed characters left

Solution:

Please put this into Consolevariable.ini (best is in the last line, don't add any characters before the line):

r.GraphicsAdapter = -2

You can verify the setting was applied in the console typing in "r.GraphicsAdapter" to get the current value. If you don't see it set to -2 there might be a typo. Please let us know if this does not solve your framerate drop. Thank you!

more ▼

answered Apr 26 '14 at 12:20 AM

Martin Mittring gravatar image

Martin Mittring STAFF
273 10 3 6

knack gravatar image knack Apr 26 '14 at 11:23 PM

I read that in the forum but not work

if i type in console r.GraphicsAdapater return -2

Anyway today i don't known what up but 'effects' load at 20fps not like 4.0 but now load.

LogD3D11RHI: Found D3D11 adapter 0: AMD Radeon HD 7700 Series (Feature Level 11_0) LogD3D11RHI: Adapter has 1008MB of dedicated video memory, 0MB of dedicated system memory, and 1791MB of shared system memory LogD3D11RHI: Chosen D3D11 Adapter Id = 0

Alexander Paschall gravatar image Alexander Paschall ♦♦ STAFF Apr 28 '14 at 11:05 PM

SOLUTION #1:

The fix will be in a future version of the launcher, but for now, you can edit Consolevariable.ini to change the console settings that may be the cause of the issue.

 Go to: C:\Program Files\Unreal Engine\4.1\Engine\Config
 Put this into Consolevariable.ini:

r.GraphicsAdapter = -2

SOLUTION #2:

If the first solution does not help, please download and follow the QFE instructions from here:

https://forums.unrealengine.com/showthread.php?3147-Current-Available-Quick-Fix-Solutions

(comments are locked)
10|2000 characters needed characters left

I got this solution from Nick Penwarden. This apply where you only have Intel HD graphics adapter but UE4.1 select Software renderer instead. My test level FPS up from 1-3FPS to 70FPS on Low Quality and 20FPS on Epic Quality. Just like the old UE4.0.2 Big thanks to him.

Add these lines to MyProject\Config\DefaultEngine.ini

[SystemSettings]

r.GraphicAdapter=-2

Here's the snipped on the log after the changes:

LogD3D11RHI: Found D3D11 adapter 0: Intel(R) HD Graphics Family (Feature Level 11_0) LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 1792MB of shared system memory

LogD3D11RHI: Found D3D11 adapter 1: Microsoft Basic Render Driver (Feature Level 11_0) LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 256MB of shared system memory

LogD3D11RHI: Chosen D3D11 Adapter Id = 0

more ▼

answered Apr 25 '14 at 06:25 PM

RinDreamX gravatar image

RinDreamX
53 4 7 13

Edkenway gravatar image Edkenway Apr 25 '14 at 09:51 PM

So, can you post a screen-shot of how you have it, in the DefaultEngine.ini?

RinDreamX gravatar image RinDreamX Apr 26 '14 at 03:53 AM

Just copy and paste it at the end of the DefaultEngine.ini

[SystemSettings]

r.GraphicAdapter=-2

(comments are locked)
10|2000 characters needed characters left

Not work for me.

if try play/load effects or element i must force close after ten minuts with CPU 100% and another 10 minuts for try kill UE4 process.

effect play fine with 4.0*

EDIT: that looping script its from UE? Script: chrome://browser/content/preferences/applications.js:1192

not the first time a popup jump because a script its eating my resources since update. ¿perhaps some bug in a script are looping a eating resources?

link text

dxdiag.txt (32.5 kB)
more ▼

answered Apr 25 '14 at 11:27 PM

knack gravatar image

knack
26 2 7 7

(comments are locked)
10|2000 characters needed characters left

Big drop of FPS for me. GTX 670, i7, 16 GB Memory (running inside viewport).

Here's the reflection scene in 4.0.1:

alt text

Same scene running in 4.1.0:

alt text

more ▼

answered Apr 26 '14 at 06:01 AM

Onoa gravatar image

Onoa
46 2 5 6

joe.real gravatar image joe.real Apr 26 '14 at 05:16 PM

I had a similar experience. Try "ESC" out to the editor, then re-enter "Play" -> "Selected Viewport". I posted my findings HERE

Zeeker gravatar image Zeeker Apr 26 '14 at 10:44 PM

Can someone please show me a step by step to do this. Thank you...

Martin Mittring gravatar image Martin Mittring STAFF Apr 28 '14 at 03:50 PM

We are working on sucha guide but the shown performance drop is likely not related to the same thing. The guide would help to solve a problem where it was using software rendering instead of hardware accelerated rendering. The drop here seems large and concerning but it's likely still using hardware accelerated rendering. Using the console command ProfileGPU might help. We also work on a large performance profiling document but it needs a bit more time/polish.

(comments are locked)
10|2000 characters needed characters left

Intel i7-2600 CPU @ 3.40 GHz 12 GB RAM dual monitors NVIDIA GeForce GT 545

Effects Cave frame rate ~ 24 fps

  1. Clarification: should the INI change be under [Startup] or [SystemSettings]?

  2. Given my system specs what should the expect framerate be for the Effects Cave? ShadowKindGames :: Effects Cave :: 45 - 50 FPS

I noticed in the log that the engine is indeed selecting the correct graphics driver.

NOTE: We only used 4.1

more ▼

answered May 01 '14 at 08:06 PM

Jerry.Richards gravatar image

Jerry.Richards
1 1 1 4

Jerry.Richards gravatar image Jerry.Richards May 02 '14 at 03:32 AM

I'm not sure if it's at all related, but I suspect it may be the case, even a simple project makes my system hum. And I mean huuuuuuumm.

I'm following along with the Hello World, which is basically an empty scene, and it has my system fan spinning.

(comments are locked)
10|2000 characters needed characters left

My case:

I have a laptop with dual GPU, one Intel 4000 with 1 Gb, one Geforce GTX 660 M with 2 Gb. My FPS was between 4 and 6.

I made the change in Consolevariables.ini and Defaultengine.ini

Not work

Then I just realize the Geforce GPU will work only in Fullscreen mode, I setup the editor for fullscreen, But it didn't works at the first run, then I closed and opened again, It begin to works but crashed several times, then I went to Nvidia site and I got the latest drivers for my GPU, run again and....

IT WORKS!!!

Now i have 20-25 FPS (medium)... some demo i have 30-32 and other i have 18-20, but it is enough to work and enjoy this powerful engine.

I think EPIC / Unreal team must to be more clear about this kind of subjects... I used 3 hours to resolve this technical issue. I was pretty close to cancel my subscription. Just something like this:

Laptop users with dual GPU:

  • Be sure to run in fullscreen mode to enable the gaming GPU.

  • Install the latest drivers for your GPU.

If I had this 2 simple lines i was able to solve this issue in 2 mins and saved a lot of time.

more ▼

answered May 24 '14 at 08:18 PM

xpectral gravatar image

xpectral
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question