x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Editors not launching - 9% Initializing

Hello, I cant get unreal to start up at all. It just sits at 9% seemingly doing nothing.

I also cant launch 4.10, and the 'verify' button for each is grey out and cannot be clicked.

I first noticed this issue with just one project a couple of days ago, (a pretty much unaltered shooter example I was using to test out things in.)

But now after installing 4.10, I am having this issue with everything.

Please help me, this is a big issue for me as I literally cant do anything here. My internet is painfully slow as well, so just reinstalling it and downloading the engines is not ideal as it will take me over a day per Version.

Thanks, Graeme

Product Version: UE 4.9
Tags:
more ▼

asked Dec 20 '15 at 10:54 AM in Bug Reports

avatar image

GreyDesigns
16 7 8 11

avatar image GreyDesigns Dec 20 '15 at 01:29 PM

I have now managed to verify both engines, but it had no effect. they still hang at 9%...

avatar image GreyDesigns Dec 20 '15 at 02:29 PM

I have uninstalled both Engines, and removed the folders from the Epic Games folder - I will now just install 4.10.1 and see if I have any luck.

I will update once that is done downloading, still looking for tips and advice though.

avatar image GreyDesigns Dec 20 '15 at 11:16 PM

Versions 4.10.1 has finally finished downloading again, and frustration continues.

Still stuck at 9% - how can this be?

avatar image GreyDesigns Dec 21 '15 at 09:12 AM

Uninstalled again, this time including launcher. Fresh installed launcher, now downloading 4.10.1 again.

avatar image Sean L ♦♦ STAFF Dec 21 '15 at 02:50 PM

Hello,

Please post an update once your launcher and 4.10.1 install finishes and let us know if that works for you. If not, I will be glad to offer some suggestions in an attempt to get your issue resolved. Thank you.

avatar image GreyDesigns Dec 21 '15 at 03:32 PM

Hi Sean, thanks for getting in touch, I really appreciate that.

I thought it was going to work this time, when it was done installing 4.10 I launched it, and it got as far as showing me my projects. I clicked on my existing 4.9 project, and made a copy to 4.10. And then installed the Substance plugin. now when I try to launch, it is getting stuck at 9% again.

Is there anyway of removing the substance plugin now that I have installed it?

It could of course be coincidence however.

avatar image Sean L ♦♦ STAFF Dec 21 '15 at 03:44 PM

There is a post that details how to remove plugins outside of the editor that you can have a look at: https://answers.unrealengine.com/questions/84205/disable-plugins-outside-of-editor.html Let me know if the advice given in that post helps you out. Following the steps in that post should allow you to disable the plugin without having to go into the editor.

avatar image GreyDesigns Dec 21 '15 at 03:45 PM

Ah, I just found the remove button in the dropdown next to launch. Still stopping at 9% though.

avatar image Sean L ♦♦ STAFF Dec 21 '15 at 03:51 PM

Give this a try, go to this file path: C:\Users\YourUserName\AppData\Local\UnrealEngine\4.10 and delete the Saved, Intermediate, and DerivedDataCache folders. Then attempt to reinstall the engine. Deleting the files located in the installation directory unfortunately does not remove all of the files relating to that engine version, so removing these folders and performing a clean install should fix the issue.

avatar image GreyDesigns Dec 21 '15 at 04:13 PM

Okay, Thanks Sean.

I will give that a go! And update here asap.

Thanks again!

avatar image Sean L ♦♦ STAFF Dec 22 '15 at 01:08 PM
  • So the issue seems to be you can open up a project initially, but the second time you try to open a project it freezes at 9%?

  • Could you provide your dxdiag?

  • How long are you letting the project sit before ending the process? Is it possible that it is just taking an unusually long amount of time to open?

Thank you

avatar image GreyDesigns Dec 22 '15 at 07:45 PM

Hi Sean,

Yes, from what I can gather that is the issue.

and sure - (dxdiag should be attached here)link text

And I have left it like that for hours and it has done nothing.

Thanks again, this is a major roadblock for me and I appreciate your help so far.

dxdiag-unreal.txt (38.6 kB)
avatar image Sean L ♦♦ STAFF Dec 22 '15 at 07:52 PM

It doesn't look like you have the latest drivers from what I can see in your DxDiag. Go ahead and update those to the latest and give it another shot.

avatar image GreyDesigns Dec 23 '15 at 01:41 PM

I have installed the latest Nvidia driver now, and also used Ccleaner to fix all registry issues. Are there any other drivers you would recommend updating?

avatar image Sean L ♦♦ STAFF Dec 23 '15 at 02:17 PM

It is recommended that you keep both your graphics card drivers and OS updated at all times. Since you have updated, go ahead and give it another try and see if you can get past 9%.

avatar image GreyDesigns Dec 24 '15 at 10:23 AM

Everything updated, but it still stops at 9%. I'm going to try a fresh install again, but this time only install 4.9, see if my luck improves.

avatar image Sean L ♦♦ STAFF Dec 24 '15 at 01:47 PM

Could you attempt to open another project and get the Logs from the project's saved folder and then upload those here? I'd like to see if we can figure out exactly what is causing it to freeze at 9%. Thank you

avatar image GreyDesigns Dec 24 '15 at 08:01 PM

Damn, no luck. It finished installing again last night, and like the last time, the first launch went well, and i was able to open it up like normal. This time I went straight to making a blank 4.10 project, and it opened up fine. I closed it all down thinking the issue was resolved. But then this morning I went to check it (making this the second launch again) and it is stuck at 9%, and this time I haven't touched any plugins or anything. What should I do next?

avatar image Sean L ♦♦ STAFF Dec 28 '15 at 04:27 PM

Hello,

I am marking this post as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day,

Sean Flint

avatar image GreyDesigns Dec 30 '15 at 11:31 AM

Hello Sean, sorry for not getting back to you sooner, the problem is still here after installing back to just 4.9.2, unfortunately.

I will attach the logs from my main project, hopefully there are some clues in there!

Thank you again.

link text

link text

link text

link text

avatar image GreyDesigns Dec 30 '15 at 11:34 AM

These logs were taken while it was stuck at 9% btw

avatar image Sean L ♦♦ STAFF Dec 30 '15 at 02:10 PM

C:\Program Files\Epic Games\4.10\Engine\Binaries\Win64

Navigate to that folder path and attempt to open the UE4Editor.exe instead of opening the engine from the launcher. Let me know if there are any different results.

avatar image GreyDesigns Dec 30 '15 at 03:02 PM

No, same result I'm afraid

avatar image Sean L ♦♦ STAFF Dec 30 '15 at 04:01 PM

I have a couple more questions:

  • Are you using an Oculus at all?

  • Do you happen to have any Antivirus software that could be interfering with the engine?

  • Is your Verify button still grayed out in the Launcher?

Thank you.

avatar image GreyDesigns Dec 30 '15 at 06:11 PM
  1. I do have an oculus, but I haven't used it with UE4, and have unplugging it and made sure that the SDK isn't running also - Should I uninstall Oculus SDK for testing?

  2. Only the built in windows defender, I have tried turning it off also, but no effect.

  3. And no, the verify button is back. But verifying it is having no effect.

Thanks again.

avatar image Sean L ♦♦ STAFF Jan 05 '16 at 09:05 PM

Hello,

Could you please create a shortcut to your .uproject file, and add the -FORCELOGFLUSH command to the Target field when you right click the shortcut and open the properties window?

Here is an example of what I mean:

alt text

After doing the -FORCELOGFLUSH, could you try the same, but with -opengl instead?

Please provide the logs, one after trying each of these, two in total.

shortcut.png (77.9 kB)
avatar image GreyDesigns Jan 05 '16 at 11:38 PM

Certainly Sean, here are the logs, first forcelogflush and then opengl. Thanks again.

link text

link text

EDIT -

I have just noticed that these backup logs and the main .log have differences - "[2016.01.05-23.27.26:155][ 0]LogRHI: Texture pool" FOR "[2016.01.05-23.21.54:267][ 0]LogRHI: Texture pool i"

Does it need to be the main log file?

avatar image Sean L ♦♦ STAFF Jan 06 '16 at 01:32 PM

Just to be clear, these logs were grabbed after running the project from that shortcut using the commands that were listed in my previous post, correct? Definitely grab the main log file as well if you can.

avatar image GreyDesigns Jan 06 '16 at 09:20 PM

Yeah that's right, I entered the commands as per your image, and then just double clicked the shortcut to launch each time, then copied the logs right after stopping the failed launch.

Here are the logs today, this time not from the backups.

Thanks again!

link text

link text

avatar image Sean L ♦♦ STAFF Jan 07 '16 at 02:53 PM

It looks like you'll need to grab the logs using a different method, give this a try:

Head to this file path (if you have your engine installed in the default directory) C:\Program Files\Epic Games\4.9\Engine\Binaries\Win64

Open up a command window (Shift+Right Click-> Open Command Window Here)

Type in UE4Editor.exe -FORCELOGFLUSH

Hit Enter

After the engine opens (or in your case, freezes at 9%), then grab the logs again.

avatar image GreyDesigns Jan 07 '16 at 10:50 PM

Where do I find the logs while launching this way? Since the logs in the project saved folder aren't updated, as it wasn't opened. Thanks

avatar image Ben Halliday STAFF Jan 07 '16 at 10:54 PM

Hey GreyDesigns,

These should still be in your project's \Saved\Logs\ folder. Once the engine opens, it should present you with the Project Launcher, from which you'll be able to open the project.

You'll know it was updated as expected by looking for a line in the log that reads, "LogInit: Command line: -FORCELOGFLUSH"

avatar image GreyDesigns Jan 08 '16 at 12:35 PM

Hi Ben, Thanks, but It doesn't make it to the project launcher though, as it stops at 9%. :(

avatar image Sean L ♦♦ STAFF Jan 08 '16 at 01:49 PM

Go ahead and repeat the same process (i.e. running the editor using the command line and the -FORCELOGFLUSH command), and grab the logs located in this file path (assuming you're using 4.10. If not, just replace 4.10 with whatever version you're using): C:\Users\YourUsernameHere\AppData\Local\UnrealEngine\4.10\Saved\Logs

avatar image GreyDesigns Jan 08 '16 at 03:02 PM

Cool, Thanks It was where you said.

Here is the log from last night.

link text

ue4.log (4.7 kB)
avatar image Sean L ♦♦ STAFF Jan 08 '16 at 06:07 PM

Okay, it's starting to look like one of the DLL's could possibly be causing this issue.

Try the same process using the command line, but in addition to -FORCELOGFLUSH, also add this line -logcmds="log LogModuleManager verbose"

Then, grab the logs from that same folder as last time, and we should be able to tell exactly where it is failing.

avatar image GreyDesigns Jan 08 '16 at 07:31 PM

Here is the latest log with the additional command line, thanks!

link text

ue4.log (4.8 kB)
avatar image Mark Woodrow Jan 11 '16 at 09:17 AM

I am having the exact same issue, look forward to a fix

avatar image Sean L ♦♦ STAFF Jan 11 '16 at 07:29 PM

Hello Mark,

Could you please provide your DxDiag?

avatar image Mark Woodrow Jan 12 '16 at 08:59 AM
dxdiag.txt (50.9 kB)
avatar image Mark Woodrow Jan 12 '16 at 09:03 AM

Hello,

Please find dxdiag attached,

Many thankslink text

dxdiag.txt (50.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I have now sorted the problem, there was malware on my pc which a scan picked up, having deleted this UE4 no opens perfectly every time.

more ▼

answered Jan 12 '16 at 03:43 PM

avatar image

Mark Woodrow
26 1 2 1

avatar image GreyDesigns Jan 12 '16 at 04:28 PM

Interesting, Thanks for posting your solution, Mark. I had done a full scan with Windows Defender when the issue first came up, I'm going to do one with AVG now too just to double check though. Thanks again

avatar image Sean L ♦♦ STAFF Jan 12 '16 at 04:50 PM

Hello GreyDesigns,

It looks like with the logs you posted most recently, using the -FORCELOGFLUSH -logcmds="log logmodulemanager verbose" failed to produce properly. Could you please try again, but ensure that you include the space between log and logmodulemanager? That seems to be the issue with the last logs.

avatar image GreyDesigns Jan 12 '16 at 05:24 PM

Bingo! I ran AVG and Malwarebytes, both found a heap of stuff that windows hadn't seen. And as with Mark, unreal seems to be booting exactly as it should now. I still need to download all my plugins to open my actual projects, but I'm pretty certain that malware was the issue too.

Thanks for all your help Sean, I know I have taken up a considerable amount of your time, It was much appreciated though. Sorry that I missed such an easy fix, I should have thought to check with another scanner to begin with.

And thanks again Mark!

I look forward to getting back to my projects now though! :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question