x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

You can't join LAN Session using steam subsystem in 4.10.1

I tryed Multiplayer Shootout, in UE 4.10 You can't join LAN Session, but it perfectly works in UE 4.9

I also tryed to switch from steam subsystem to null and it worked fine (UE 4.10.1)

On UE 4.10.1 there is also another wierd bug, alt text

After calling this event I'm transfered to Map_02 and in the next frame I get back to previous map (that also happens only on steam subsystem)

English is not my native language, hope You'll understand the problem.

Product Version: UE 4.10
Tags:
session bug.jpg (100.4 kB)
more ▼

asked Dec 21 '15 at 10:22 PM in Bug Reports

avatar image

MateuszW93
101 3 5 25

avatar image Ben Halliday STAFF Dec 24 '15 at 04:21 PM

Hi MateuszW93,

I'm seeing the same inability to connect two packaged games on the same machine using the Steam OSS, and I'll be investigating further and entering a bug soon.

Your second issue, however, is new to me. Can you reproduce this in a new project? If so, could you create a small test project that displays this behavior and upload it somewhere for me? A few more questions:

  • Does this only happen in a packaged game, or does it occur in the editor as well?

  • Can you provide the logs for both server and client when this occurs? If it's happening in the editor, these will be in the project's \Saved\Logs folder. If it's in a packaged game, they'll be in the game's \GameName\Saved\Logs folder.

Thanks!

avatar image MateuszW93 Dec 26 '15 at 03:59 PM

Hi Ben Halliday,

Accually I don't have the problem with changing maps anymore, guess it fixed it self by the engine restart.

Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hello!

Actually in our Project (Steamworks v135 & UE 4.10.1) we have the same problem with the OnlineSubsystemSteam and LAN Games. With the integration of Steamworks, the game is unable to find Listen Server across the LAN, both Standalone Game mode (PIE) and Packaged Game.

I wonder if there is information on this subject.

Thanks in advance for your attention!

more ▼

answered Jan 22 '16 at 04:23 PM

avatar image

anderson.rubio
31 7 2

avatar image Ben Halliday STAFF Jan 22 '16 at 05:04 PM

There is no new information on UE-24894 at this time. For the time being, in 4.10.1 and beyond, it isn't possible to connect two instances of a game using Steam on the same machine, with LAN or otherwise.

If you are experiencing this when attempting to connect between two different machines, than this is a separate issue and I'd ask you to make a new post so we can track it properly. Before that, however, keep in mind that we do not support Steamworks v135. The default in 4.10.1 is v132, and if you've customized your engine to use something different than we can't really offer support on that. I'd recommend switching back to v132 if at all possible.

avatar image ph33x Mar 01 '18 at 10:44 PM

I'm currently experiencing an issue I'm trying to fully solve, but seems for me I cannot join LAN sessions while Steam is running.

It connects to LAN in PIE, I see the broadcasts, but between 2 instances of the game standalone or packaged.

After digging around and a restart it worked, then after a bit it didn't again. All I had done was launch Steam and Discord. So I quit both and it worked again. Launched one at a time and turns out if I have Steam running it wont LAN connect.

So, while it's not an ultimate fix (and I got here Googling the issue) you could try closing Steam and seeing if that gets your LAN session working. Saves doing what I was doing, chasing code and pulling out old projects to find out even the earliest ones don't work.

avatar image gon. May 03 '18 at 12:50 AM

Have exactly the same problem here. Any news or tips or trick or workaround to go over this or handle the situation? Is it possible to use OSS Null when LANCheckbox is true and SteamOSS when is false? Im using 4.18.3 and Advanced Sessions. Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi MateuszW93,

Glad the map situation isn't occurring for you anymore. Please let us know if the problem starts happening again.

I have not been able to confirm whether the change to make multiple game instances on the same machine unable to connect was intentional, so I've entered a bug report for it (UE-24894). It appears this was fine in 4.10.0, so if absolutely necessary to test on one machine, you should be able to grab the 4.10.0 version from GitHub and build it from source. Otherwise, testing on separate machines should work fine.

more ▼

answered Jan 04 '16 at 07:26 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The problem of going back to the previous map is because the GameName on your DefaultEngine.ini has to be the same as your project, else Steam will reject your connection, even after session was successfuly created.

more ▼

answered May 05 '16 at 01:25 PM

avatar image

jblaswu
813 21 11 46

avatar image Muzaheed Nov 04 '16 at 05:55 AM

hi. which GameName field u r talking about? I dont see any GameName field in DefaultEngine.ini

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question