x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender to UE4 Amature/bone rotation & scale problem

UE 4.10.1

I just encountered this problem where I rigged my model. Every bone is working in blender.

Here though, in UE4's skeletal mesh previewer, I try to rotate the bone to do some testing. I rotated like 160 degree already, but the bone barely rotated like 5 degree.

alt text

This phenomenon also appears with the scale transform, but there is no need for another screenshot.

However, move transform works perfectly, as you can see below:

alt text

Did anyone encountered this weird problem lately? Very weird problem.

Product Version: UE 4.10
Tags:
shot_18.png (390.0 kB)
shot_17.png (391.8 kB)
more ▼

asked Dec 22 '15 at 04:21 AM in Bug Reports

avatar image

RemoteCrab131
12 10 13 15

avatar image Matt.Williams Dec 22 '15 at 08:57 PM

Hey RemoteCrab,

I haven't run into this in some of the Blender testing we've done. Can you show me your export and import settings?

I'd also like to grab a copy of your FBX (and maybe the asset up in a blank UE4 project), if that's ok. You can upload to a file sharing service and PM me the link on the forums.

-Matt W.

avatar image RemoteCrab131 Dec 22 '15 at 09:52 PM

Hi, Matt.

I've sent you a PM through UE4 forum. It should contain a google drive link to all the files zipped which is related to this problem. I checked with my blender, I am actually using the default FBX exporter addon, so my guess about it been the exporter's problem is invalid.

I hope to find out where it went wrong. It's my first time doing rigging, also first time exporting it to UE4, but I'm confident I did most of the things right.

My blender version is 2.76b.

-Brent L.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Did you check to see if the bone roll axis is oriented correctly in blender?

more ▼

answered Dec 22 '15 at 05:27 AM

avatar image

EyeDee10Tee
2.1k 59 14 128

avatar image RemoteCrab131 Dec 22 '15 at 09:24 PM

@EyeDee10Tee

The rolls are different for most of the bones, how do I check if the bone is oriented correctly? I mean, visually I can't find any problem in blender.

avatar image JBogart Mar 05 '16 at 01:53 AM

You can click axes in the display section of the armature panel.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had this problem with the default scene settings. After changing the scene units to meters and 0.01 scale (and resizing everything) things are now working perfectly.

alt text

scenesettings.png (24.7 kB)
more ▼

answered Dec 22 '15 at 11:34 PM

avatar image

cyaoeu
153 9 14 23

avatar image EyeDee10Tee Dec 24 '15 at 09:15 AM

Ok I am glad it works now. In the bone properties panel you can select to see the direction the axis on the bones. With the bone selected you can hit alt-n to get the option to recalculate the axis. Always make sure all bones are aligned to the same roll or sometimes you get unnatural movements. It's more of a problem for multiple bone chains like in a humanoid arm or fingers.

avatar image RemoteCrab131 Dec 29 '15 at 03:57 PM

I accidentally deleted the comment because i accidently converted it to answer. lol

I tried yours first but I didn't set up the scales for my models and armatures properly for the scene scale of 0.01, thus the first try didn't work. Now I tried it again with proper scaling, it all works fine now. Thanks for the help.

I previously heard some of my co-league saying the default blender unit scale with 1.0 works fine. and I didn't realize he probably meant for static mesh.

avatar image cyaoeu Dec 29 '15 at 02:22 AM

Are you sure you have applied the transforms in blender? Scene scale should be 0.01, armature scale should be 1.000 and the mesh scale should also be 1.000. The z dimensions of your mesh should say 2m or something in that ballpark. No scaling in the fbx export settings. This should fix the issue assuming you're using the latest blender version (2.76b at this time).

avatar image RemoteCrab131 Dec 29 '15 at 03:55 PM

It works now, thanks for the details. It's much appreciated.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question