x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug] Particle visually disappearing at certain angles

So currently one if the particles I made visually disappears at certain angles, in the cascade as well as in the editor/pie/in game.

If I export the whole particle array into an empty particle emitter the problem does not transfer. If I copy the particle emitter (duplicate) the problem is still there though. So it might be a once in a blue-moon bug but I do think you guys would want to know about it. I did export the particle, send it to a friend who then imported it and the same problem occurred. Yet it did not happen when he imported the copied/duplicated version.

I got the file uploaded to dropbox, but I rather not post it (with all the containing meshes/materials) for nda-esque reasons.

Can an admin please supply me with an email so they can take a look at it? (and hope the problem is still there so they can swat the bug)

Here is a video of the bugged particle emitter: http://i.gyazo.com/b30217606403b33cbfaea7db4b5668fd.mp4

And here is one where I copied the array to an empty particle emitter: http://i.gyazo.com/6a9ff6772f58736908b5b8a0daa3c887.mp4

Product Version: Not Selected
Tags:
more ▼

asked Apr 26 '14 at 02:28 AM in Bug Reports

avatar image

Luos
9.3k 286 65 330

avatar image mufaya Mar 04 '17 at 01:43 PM

can you tell me which version of unreal engine fixed this problem? cause I'm still suffering it... I'm using 4.13

avatar image Luos Mar 05 '17 at 03:18 PM

you know this isnt an answer to a question, but a question to a question right?

anyways, set bounds properly and reboot ue4.

avatar image mufaya Mar 05 '17 at 04:57 PM

I know :)... I accidently posted it as answer... realized that like 1 sec later... ty anyways, I found it already :)

avatar image tschmi22 Apr 25 '17 at 10:53 PM

What was your solution Mufaya?

avatar image mufaya Apr 26 '17 at 10:16 AM

they were right... tick set fixed bounds and put large numbers with - in minimum and + to max... don't make it auto. if you have issue on actor collision aswell, untick drop detail and collision range limit in the actor collision component.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Do you have fixed bounds set on your particle system? If your bounds are not set correctly you may get odd rendering issues, especially with GPU particles when you reach the edge of the view frustum. If you exported into a new effect I would expect the bounds properties to transfer over, but perhaps there is a bug? Please make sure your GPU effect is within the bounding box of the effect (click the bounds button in Cascade.)

Is this only happening in the Cascade viewport?

Does this exhibit the same behavior outside of Cascade when placed into an empty level?

more ▼

answered Apr 26 '14 at 02:40 AM

avatar image

[Epic]homeRye STAFF
1.2k 22 3 42

avatar image Luos Apr 26 '14 at 02:54 AM

To quote my first line: "So currently one if the particles I made visually disappears at certain angles, in the cascade as well as in the editor/pie/in game."

The bounds are the first thing I expected it to be, but even from -100k to +100k (the particle itself is only 200 long (and yes I tried that and various other bound sizes) and the problem still occurred.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You need to increase the bounds of your particle system. When the bound is too small and it gets out of screen the whole particle system disappears.

more ▼

answered Apr 26 '14 at 02:38 AM

avatar image

Jacky
16.8k 671 167 677

avatar image Luos Apr 26 '14 at 02:53 AM

Even when the bounds are from -100k to 100k it still occurs.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

more ▼

answered Oct 03 '14 at 05:20 PM

avatar image Luos Oct 04 '14 at 01:33 AM

Works fine now!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question