x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird shadows appear with static lighting

So I have a room that looks like this: alt text And I have a certain event where the room will rotate 90 degrees. When that happens some weird shadows occur. alt text Now of course if I change all my point lights to dynamic and attach them to the room (which makes them rotate with the room) then these shadows don't appear however I have alot of point lights and it slows down the performance of my game alot of I use dynamic lights. I have checked the light as if static box for my walls but even if I didn't these shadows would still appear. So how can I use static lights and not have these shadows appear when my room rotates 90 degrees? In other words how can I have the lighting stay exactly the same when the room rotates?

Product Version: UE 4.8
Tags:
room.png (935.3 kB)
shadows.png (900.5 kB)
more ▼

asked Dec 25 '15 at 09:16 AM in Rendering

avatar image

Brandon236
88 28 38 45

avatar image Jacky Dec 26 '15 at 01:42 AM

If you want to use static lighting in the level but keep those meshes dynamic then set their mobility to movable then rebuild the lights. If you want to use fully dynamic lighting, set your lights mobility to Movable, enable Force NoPrecomputed Lighting in World Settings and then build the lights.

avatar image Brandon236 Dec 26 '15 at 05:21 AM

Again, making my lights movable makes the game extremely slow but will enabling force NoPrecomputed Lighting help speed things up?

avatar image Brandon236 Dec 27 '15 at 09:18 AM

Ok here's what I did. I set the meshes to movable and rebuilt the lights but the shadows still appear. I then set the lights to dynamic, built the lights and the game ran extremely slow so that's clearly not going to work. I really don't understand how I can make my walls always have the exact same lighting no matter where they are.

avatar image Jacky Dec 27 '15 at 04:19 PM

Weird thing is those walls should be lit fine with static(mobility set to stationary) lighting when the meshes are movable. Is the light source intersecting with anything? Can you provide a sample project?

avatar image Brandon236 Dec 28 '15 at 04:16 AM

I thought the lighting becomes dynamic when the mobility is set to stationary. The thing is I can't set my lights to stationary because then my game will lag like crazy so the lights have to be static.

avatar image Jacky Dec 28 '15 at 01:27 PM

No, stationary is also static. The difference between static and stationary mobility is that stationary lights also light dynamic objects. So you should use stationary lights whenever possible.

avatar image Brandon236 Dec 29 '15 at 02:02 AM

But stationary lights lag my game because there's alot of point lights so I have to use static lighting. So my meshes have to have the "light as if static" option just so the lights appear which does work until the room rotates and those weird shadows appear.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Select the object that is the room and either remove any lightmaps it has or just turn off its ability to cast shadows at the top of the details panel perhaps?

more ▼

answered Dec 25 '15 at 06:31 PM

avatar image

Halocomander1
49 6 12 14

avatar image Brandon236 Dec 25 '15 at 10:59 PM

I tried turning off casting shadows but that didn't work. How am I supposed to turn off lightmaps. The room is made up of the mesh Floor_400x400 which is not a custom mesh. So how can I turn off lightmaps. I do have a lightmass important volume but changing the size and position of that doesn't seem to work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question