Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.10.1] Crash on Windows cooked 32 bit


i discover a problem with the Open Level, it was working a long time, but suddenly it crashes the standalone 32x, launch the crash reporter but no crash log is available.

The game starts in the main menu, where you can choose if you want to start, on start it will use the open level BP to load the new level, after a while of loading i am back on the desktop and the crash reporter pops up with no created log files.

I didnt change anything to the menus, everything was working before, i changed many things to the level i want to load.

64 bit Standalone is working fine, in the editor it is working too.

Thank you for your help!

Product Version: UE 4.10
more ▼

asked Dec 26 '15 at 06:07 AM in Packaging & Deployment

avatar image

86 4 8 11

avatar image GreenWolf Jan 13 '16 at 09:54 PM

no one can help?

avatar image Matthew J Jan 15 '16 at 09:33 PM

Hello GreenWolf,

Could you post the logs from when you packaged the game? There could be some warnings there that could point to why the 32x packaged game is crashing on you.

avatar image GreenWolf Jan 17 '16 at 07:29 AM

I will pack the game tomorrow, can i send you the crashlog via private message?

Thank you for your help!

avatar image Matthew J Jan 18 '16 at 01:59 PM

Of course, you can send it to me in a private message on our forums. Here is a link to my profile.

avatar image Matthew J Jan 19 '16 at 01:50 PM

Thank you for sending me the logs, GreenWolf. I've found some warnings that may be pointing to some problems.

MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2016.01.19-09.45.05:016][ 0]LogInit:Display: LogLinker:Warning: CreateExport: Failed to load Parent for Function /Game/Objectfin/Parts/Decoration/Anvil01_SC.Anvil01_SC_C:UserConstructionScript; removing parent information, but keeping function

This is repeated multiple times for different assets. From looking up the error it seems like a problem that occurs when converting a project to 4.10 from a previous version of the engine. Has this been done for this project? I'm not quite sure why this would only be giving you problems in 32 bit as of yet, but I'll continue looking into it.

avatar image GreenWolf Jan 20 '16 at 06:05 AM

yes it is a converted project over a couple of unreal engine releases. It is working when using 64 bit. The problem with parent appears in 64 bit too, but the standalone is still working.

avatar image Matthew J Jan 21 '16 at 02:05 PM

A few more questions for you:

  1. What OS version are you using?

  2. Are you building for Development or Shipping?

  3. Just to be sure, can you try packaging a new empty project?

  4. If you have time, can you try migrating the content from your current project to a new project? The conversion process may of caused a problem.

avatar image GreenWolf Jan 22 '16 at 09:21 PM

Thank you for your answer!

  1. Windows 10

  2. Shipping

  3. Yes i can, i can package the 32Bit of my game too, the menu level is working, its a problem while loading the whole content of the huge level i think, maybe run out of memory?

  4. I would like to avoid this, because of the required time i would need for this.

I think its a memory problem, cause it is working if i remove some of the content.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Thank you for the detailed reproduction steps, Greenwolf. I've placed a bug in for the issue under the number UE-26620. It seems that you have a workaround for now but I'll be sure to let you know if any updates are made to the issue. There is one thing I wanted to mention however. If you're packaging with Static runtime generation, the Invokers will not be taken into account.

As for the issue with the crashes when using Dynamic, it seems to be a project specific issue or at least something more complicated. I'll need a copy of your project to look further into this particular problem.

P.S. This is a second time posting this, Answerhub decided to toss my post into the abyss when I tried to convert from comment to an answer.

more ▼

answered Feb 12 '16 at 01:57 PM

avatar image Matthew J Feb 23 '16 at 08:31 PM

Hello GreenWolf,

I've just verified a fix for this issue on one of our latest internal builds. It should be included in an upcoming update to the engine. I'm not quite sure which one in particular unfortunately.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Running out of memory normally results in a crash report that lets you know something to that extent.

As far as migrating the project, it wouldn't take very long to do. Please be aware that you can migrate all of the content in your project automatically through the engine's built in "Migrate" option under Asset Actions in the Content Browser. It may take sometime for the process itself to complex depending on the amount of content but it shouldn't take much of your time.

If there is also code in this project, you'll need to copy the source folder over manually and then generate project files. If the new project's name is different than the original project, you'll also need to make some slight edits to make up for that. A find and replace should take care of that however.

more ▼

answered Jan 25 '16 at 06:32 PM

avatar image GreenWolf Jan 27 '16 at 09:26 PM

migrating the project with the same level and content seems to not crash the standalone client. I didnt use the whole settings from the other project.

Thank you very much!

avatar image Matthew J Jan 28 '16 at 01:59 PM

I'm assuming that means that the problem has been fixed? It seems as though that is what you mean but I want to be sure before marking the question as resolved.

avatar image GreenWolf Jan 28 '16 at 09:26 PM

the migrating project was working until i set up everything like in the other project. I changed the character from the spectator to my character and the 32 bit standalone is crashing again without creating a crash log

avatar image Matthew J Jan 29 '16 at 01:15 PM

As this seems like an issue with your project itself, would it be possible to get a copy of this project? If you would like to keep it private you could send a download link for it to me through a private message on our forums. Here is a link to my profile.

If you're unable to provide it, please let me know and I'll try to find the next course of action in resolving this.

avatar image GreenWolf Jan 31 '16 at 05:58 PM

I hope i can find out what the problem is without uploading, the projectfiles are 16,3gb, it will took ages to load this up. I try to remove some stuff from the map to test what the problem is.

Migrating the content to another project and package it for 32bit works fine, but if i use my character it wont work anymore in 32 bit, i just test if it works when i remove all code from the character but it isnt working atm.

It seems for me if the 32bit crashes if all stuff gets loaded and it is too much to load. Cause the level change without a problem and i use sublevels, the persistent level is already loaded and before i can see the first sublevel it crashes.

I think the problem appears since i added the navmesh.

edit: On another map it is working fine with the character, i changed something to the map that let the 32bit standalone client crash and i dont know what it is. 64bit is still working fine. The navmesh isnt the problem, i cannot figure out what the problem is, cause the map works and the character is working if they are seperated from each other.

avatar image Matthew J Feb 05 '16 at 09:11 PM

Have you had a chance to upload a copy of the project yet, GreenWolf? If the project is a code project, you can save quite a bit of space by removing the Binaries, Intermediates, Build, and Saved folders along with the .sdf file in the main directory as I should be able to generate and compile to get those if the code compiles correctly.

avatar image GreenWolf Feb 06 '16 at 04:22 PM

I think i found the problem by my self. Here is the problem how you can reproduce the problem:

  1. Create a new Project with starter content as blueprint project (blank).

  2. Create a blueprint with a navigation invoker component (Standart settings).

  3. Create a landscape (you dont need to change anything to the settings).

  4. Place the navigation invoker blueprint a couple of times on the landscape.

  5. Change setting of project to only create navmesh around navigation invokers.

  6. Create nav mesh bounds volume (very large 400000 x 400000 x 400000).

  7. Change the navigation generation in project settings to dynamic.

Package 32bit standalone for windows in shipping mode. Working as it should.

Now change the navigation generation in project settings to static again and package the 32bit standalone for windows again (It will fail).

If you change to dynamic it will work again (If you create a new project and dont change the navigation generation to dynamic it will work in static mode).

For my project if i migrate to a new project it will work with all my content, but if i change the navigation generation to dynamic the game crashes if i load that level with dynamic generation of navigation invokers (cant change it to static again cause it will abort the cooking process). I dont know why my project is crashing after switching to dynamic generation but something is different to the project after changing this setting.

The only solution how my 32 bit release is working is to migrate everything to a new project and dont change the navigation generation to dynamic.

Is there any solution for this?

edit: Change from Dynamic generation to static and restart the editor, prevents from stopping the packagin process and the 32bit is working with static generation. Using Dynamic modifiers only is working too for 32bit in my project.

avatar image Matthew J Feb 08 '16 at 03:32 PM

Hello Greenwolf,

Following your repro steps, I was able to get the packaging errors, but after changing the configuration around and restarting the editor, I was no longer able to get the same error to occur in that project. While this makes this a much less major issue, I'll be putting in a bug report for the problem as it shouldn't occur in the first place. I'll let you know when I've done that.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question