x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blending Animations are turning character around!

Hello, my problem is that the animations I captured with my 3D cam are causing problems if I think the pelvis bone is rotated. I try to rotate the bone but this destroys the animation.

Everytime unreal engine blends between two animations (eg: blendspace) the character turns 360 degrees and changes position. Is there a way to fix that in 3dsmax or in some other program?

THANK YOU :)

Product Version: UE 4.9
Tags:
more ▼

asked Dec 27 '15 at 08:52 AM in Using UE4

avatar image

Taratus
67 13 18 26

avatar image Shempii May 03 '16 at 08:56 PM

I have a related issue which I can't find answers to online.

I'm importing animations from a 3dsmax biped, and when the animation attempts to blend between another animation, it appears that spine_03 (on the mannequin) is "taking the long way" to blend into the animation. In other words, instead of rotation just a tiny distance to return to the animation (think of a use where you're blending between a punch and an idle or a running animation) the spine rotates in the complete wrong direction giving a really bizarre, exorcist effect where the character's spine spins around in a the wrong direction.

I've managed to patch this up by making the blend duration EXTREMELY short (.01) , but this isn't much of a fix because then I might as well not be using animation blending at all. The character then snaps between animations which is less than desired behavior.

It seems like it's related to your problem though, I'm curious if you ever found a solution or cause of the problem. If anybody else can weigh in here, help would be greatly appreciated.

avatar image gamelord12 Sep 27 '17 at 07:22 PM

Did anyone find a solution to this? I'm having the exact same problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I had this same problem driving me nuts for the past 3 days, and this was the only post on the internet that showed proof that someone else had this issue. I just fixed it in my project! I had a cover animation blend space for facing left, an idle and a walking animation, while standing in cover, on a 1D blend space. The idle animation was facing the wrong direction by 180 degrees, so I rotated that idle animation in Blender and spat out the fixed FBX. After that was done, I ran into the issue described in this thread. I kept trying to fix it by further modifying the idle animation, but ultimately I fixed it by running the second animation, the walking animation that was already pointed in the proper direction, through Blender and rotating it by -360 degrees. I'm not sure if it was fixed by the -360 degree rotation or if running both animations through Blender made them compatible with each other when they weren't before, but one of those two things definitely fixed it. You can see this reddit thread for more info.

more ▼

answered Sep 28 '17 at 01:16 AM

avatar image

gamelord12
6 2 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the same issue. My animation was made facing opposite direction so I imported it using 180 degrees Z rotation and my character was turning 360 degrees when blending animations as well. So I had changed import setting to -180 degrees (minus instead of plus this time), reimported and it fixed rotation. If your animation facing correct direction try to import it using -360 degrees.

more ▼

answered Nov 07 '17 at 09:17 AM

avatar image

Sioda
6 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Check rotation of all roots. Blend rotates it in mindlessly.

I fixed blending by matching roots and manually fixed pelvis. Stupid solution though, I believe there should be something built-in. Like letting know blend to rotate clockwise idk.

alt text

more ▼

answered Jan 16 '19 at 11:47 AM

avatar image

Two-faced
860 31 13 48

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question