x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unable to Build Engine from Source Code in MAC

Hi,

I tried to build the ue4 editor from source in MAC. I followed following link to do so. https://docs.unrealengine.com/latest/INT/Programming/Development/BuildingUnrealEngine/index.html

My OS X Version: OS X EI Capitan 10.11.2

Unreal Engine version: 4.8.3

Xcode versions are: 6.3 , 3.2 and 3.1

I tried in all the versions of xcode with UE-Editor Mac > My Mac.

But, I am getting following error. Here is my log file. link text

alt text

Product Version: UE 4.8
Tags:
error.png (439.8 kB)
more ▼

asked Dec 27 '15 at 10:55 AM in Installation & Setup

avatar image

L34D3R
527 21 34 51

avatar image Matthew J Dec 28 '15 at 05:14 PM

Hello L34D3R,

I've seen this issue before but I believe it has already been fixed in more recent versions of the engine. Could you try a newer version of the engine to see if the same issue persists? I understand that this may not be ideal as you may wish to develop on 4.8.3 but I would like to check if this is an issue that has been resolved in the most recent builds before proceeding.

avatar image L34D3R Dec 31 '15 at 05:09 AM

Hi Matthew,

As per your guideline, I tried to build with engine version 4.11. But I got the build failure. Here is my log file.

My OS X Version: OS X EI Capitan 10.11.2

Unreal Engine version: 4.11

Xcode versions are: 6.3 , 3.2 and 3.1

link text

4.11 log file.txt (147.3 kB)
avatar image Matthew J Jan 06 '16 at 02:22 PM

Thank you for giving that a try. I'm still looking into this issue and I'll be sure to let you know when I have any more information.

avatar image Matthew J Jan 06 '16 at 06:27 PM

Something that I came across in my research that may fix your original problem with 4.8.3 is to make sure that the file paths (namely the folder you unzipped the source into) don't contain any spaces. There were problems in previous versions of the engine that caused project generation / build failures when there were spaces as UBT wasn't handling it very well. Please let me know if this helps at all.

avatar image L34D3R Jan 12 '16 at 02:01 PM

Hi Matthew,

Thanks for the reply. Currently I don't have any space in my unzipped source folder.

/Users/Shared/UnrealEngine/UnrealEngine-4.8/

and

/Users/Shared/UnrealEngine/UnrealEngine-4.11/

I tried both the things but didn't worked out.

Regards, L34D3R

avatar image Matthew J Jan 14 '16 at 01:56 PM

Sorry to hear that wasn't it. From looking up the one error I see in your logs "clang: error: unable to execute command: Segmentation fault: 11\" it seems that this may be a problem related to XCode itself. I'm not entirely sure, but can you try uninstalling your previous versions of XCode and installing the latest non-beta version (7.2)?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

We haven't heard from you in a while, L34D3R. Have you been able to give a try to uninstalling your old XCode versions and installing the latest XCode version to see if that will help with the issue? If so, what results did that yield? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Jan 18 '16 at 02:45 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the exact same problem and resolved it by removing the spaces. I wonder if dashes and numbers pose a similar problem. In case anyone else finds themselves here, try that as well.

more ▼

answered Jun 13 '16 at 05:22 AM

avatar image

filmicarty
11 1 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question